aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDariqq <dariqq@posteo.net>2024-07-27 18:58:05 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2024-08-18 10:02:59 +0200
commit803f9d3038d3c3048079c63d51b7b40bff09f17a (patch)
treeebf285753e0edd1bb5750a1bf519883c34f9240b /gnu
parent08ec4e8e7282837ee0ba1b85c6d91d579a8cc08f (diff)
downloadguix-803f9d3038d3c3048079c63d51b7b40bff09f17a.tar.gz
guix-803f9d3038d3c3048079c63d51b7b40bff09f17a.zip
gnu: sbcl: Fix startup error on i686-linux.
Fixes <https://issues.guix.gnu.org/69106>. * gnu/packages/lisp.scm (sbcl) [arguments]: Invoke make.sh with smaller dynamic-space-size when building for x86-32. Change-Id: I08e8d2304d883973ab9a1b6a900ea9ee1679fac5 Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 4f2a95abb9..090b91610e 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -1506,8 +1506,9 @@ be built as a stand-alone REPL interpreter.")
`("clisp")))
(string-append "--prefix="
(assoc-ref outputs "out"))
- ,@(if (target-ppc32?)
- ;; 3072 is too much for this architecture.
+ ,@(if (or (target-ppc32?)
+ (target-x86-32?))
+ ;; 3072 is too much for these architectures.
`("--dynamic-space-size=2048")
`("--dynamic-space-size=3072"))
"--with-sb-core-compression"