aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-04-02 08:18:21 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-04-02 08:21:43 +1000
commit800a7dd59e39f6717231353c27984d080e261f63 (patch)
treec399b7d82f303c4b110400d7aeb837801dd420e8 /gnu
parent22a494ec25686a7a135ddc7807046e0bf049e5fb (diff)
downloadguix-800a7dd59e39f6717231353c27984d080e261f63.tar.gz
guix-800a7dd59e39f6717231353c27984d080e261f63.zip
gnu: ruby: Replace with ruby-2.3.4.
* gnu/packages/ruby.scm (ruby)[replacement]: New field. (ruby-2.3.4): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e09850f038..211f641989 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -49,6 +49,7 @@
(package
(name "ruby")
(version "2.3.3")
+ (replacement ruby-2.3.4)
(source
(origin
(method url-fetch)
@@ -101,6 +102,26 @@ a focus on simplicity and productivity.")
(home-page "https://ruby-lang.org")
(license license:ruby)))
+(define ruby-2.3.4
+ (package
+ (inherit ruby)
+ (name "ruby")
+ (version "2.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://cache.ruby-lang.org/pub/ruby/"
+ (version-major+minor version)
+ "/ruby-" version ".tar.xz"))
+ (sha256
+ (base32
+ "132p5kc1sx97svbx04g40pz5pr7p8f6jlmnq5r2prlcz5q1xj71l"))
+ (modules '((guix build utils)))
+ (snippet `(begin
+ ;; Remove bundled libffi
+ (delete-file-recursively "ext/fiddle/libffi-3.2.1")
+ #t))))))
+
(define-public ruby-2.2
(package (inherit ruby)
(replacement #f)
200'>2021-10-03bash completion: Complete ‘guix weather’ packages....* etc/completion/bash/guix (_guix_complete): Complete available package names for ‘guix weather’ when not following ‘-m’. Tobias Geerinckx-Rice 2021-10-03bash completion: Append to $COMPREPLY where possible...._guix_complete is always called with a fresh empty array. * etc/completion/bash/guix (_guix_complete_command) (_guix_complete_subcommand, _guix_complete_installed_package) (_guix_complete_option, _guix_complete_pid): Append to $COMPREPLY rather than re-assigning. Tobias Geerinckx-Rice 2021-10-03bash completion: Consolidate similar $command ‘if’ branches....* etc/completion/bash/guix (_guix_complete): Combine the ‘upgrade’ and ‘remove’ commands, as well as ‘download’, ‘gc’, and ‘hash’. Tobias Geerinckx-Rice 2021-09-29guix-install.sh: Don't swallow wget errors....Using ‘-q’ suppresses *all* stderr output, including errors. * etc/guix-install.sh (chk_gpg_keyring, guix_get_bin_list, guix_get_bin): Substitute ‘--no-verbose’ for ‘-q’. Reported by Maxim Cournoyer <maxim.cournoyer@gmail.com> Tobias Geerinckx-Rice 2021-09-29news: Adapt 'de' translation....* etc/news.scm: Mention that Guix Home is a "technology preview". Florian Pelz 2021-09-28news: Mention that Home is a "technology preview"....* etc/news.scm: Mention that Home is a "technology preview". Ludovic Courtès 2021-09-27news: Add 'de' translation....* etc/news.scm: Add German translation of Guix Home entry. Florian Pelz 2021-09-27Merge branch 'wip-guix-home'Oleg Pykhalov 2021-09-27news: Add entry about Guix Home....* etc/news.scm: Add entry. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com> Andrew Tropin 2021-09-23news: Add 'de' translation....* etc/news.scm: Add German translation of 'guix graph -M' entry. Florian Pelz 2021-09-23news: Add 'de' translation....* etc/news.scm: Add German translation of fallback to SWH entry. Florian Pelz 2021-09-22news: Add entry for Git clone fallback to SWH....Suggested by zimoun. * etc/news.scm: Add entry. Ludovic Courtès 2021-09-21news: Add entry for "guix graph -M"....* etc/news.scm: Add entry. Ludovic Courtès 2021-09-21etc: committer: Amend previous commit if a copyright line was added....Previously, the script would raise an error if a copyright line was added to a file in gnu/packages/. With this change, it will amend the previous commit whenever a copyright line is added, and add the copyright line to the commit. * etc/committer.scm.in (add-copyright-line): New procedure. (main): Check if a copyright line was added and call ‘add-copyright-line’ if necessary. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Xinglu Chen 2021-09-20etc: Add systemd files for running ‘guix gc’ periodically...* etc/guix-gc.service.in: New file. * etc/guix-gc.timer: Likewise. * .gitignore: Ignore generated ‘guix-gc.service’. * nix/local.mk (nodist_systemdservice_DATA): Add ‘guix-gc.service’ and ‘guix-gc.timer’. (EXTRA_DIST): Add ‘guix-gc.service.in’ and ‘guix-gc.timer’. * doc/guix.texi (Binary Installation): Mention the new systemd files. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Thiago Jung Bauermann 2021-09-14etc: Add 'disarchive-manifest.scm'....* etc/disarchive-manifest.scm: New file. * Makefile.am (EXTRA_DIST): Add it. Ludovic Courtès 2021-09-14etc: Add 'source-manifest.scm'....* etc/source-manifest.scm: New file. * Makefile.am (EXTRA_DIST): Add it. Ludovic Courtès