aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-03 09:24:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:45 +0200
commit7e30fd530eb2d803bebe57901e252bb3148b634e (patch)
tree6a206cf46e5dce22f15ed4e3d27fc56a55cd602e /gnu
parent2e189e8863450669c4e59ce941704fb3237b108f (diff)
downloadguix-7e30fd530eb2d803bebe57901e252bb3148b634e.tar.gz
guix-7e30fd530eb2d803bebe57901e252bb3148b634e.zip
gnu: texlive-mptopdf: Fix package.
* gnu/packages/tex.scm (texlive-mptopdf)[source]: Only grab specific "mptopdf.pl" scripts, not all other scripts in the same directory. [arguments]<#:phases>: Add a phase to use provided Perl. [inputs]: Add PERL.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 13 insertions, 6 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 54a7966f05..fa7db3c180 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1532,21 +1532,28 @@ information in the TFM file.")
(version (number->string %texlive-revision))
(source (texlive-origin
name version
- ;; The first location prevents from downloading all ConTeXt
- ;; "doc/context/scripts/mkii" directory.
(list "doc/context/scripts/mkii/mptopdf.man"
"doc/man/man1/mptopdf.1"
"doc/man/man1/mptopdf.man1.pdf"
- "scripts/context/perl/"
+ "scripts/context/perl/mptopdf.pl"
"tex/context/base/mkii/"
"tex/generic/context/mptopdf/")
(base32
- "08z0hxq0645lf8jyl0wq3kwn1f7xsvj736sqgfin9ldd89zc2ch3")))
+ "19kpqbkmz8al9wxn83fmg89fyv2pl2iqgnh256wi6pz4q3p77f0d")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
(arguments
- (list #:link-scripts #~(list "mptopdf.pl")
- #:create-formats #~(list "mptopdf")))
+ (list
+ #:link-scripts #~(list "mptopdf.pl")
+ #:create-formats #~(list "mptopdf")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-perl-header
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((perl (search-input-file inputs "/bin/perl")))
+ (substitute* "scripts/context/perl/mptopdf.pl"
+ (("exec perl") (string-append "exec " perl)))))))))
+ (inputs (list perl))
(propagated-inputs (list texlive-plain))
(home-page "https://ctan.org/pkg/mptopdf")
(synopsis "mpost to PDF, native MetaPost graphics inclusion")