aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2023-02-03 07:43:15 -0500
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:33 +0200
commit7d220b780adeded95710aa46a490bebd2f1994e7 (patch)
tree92954404f34c843bcde26746b9dd690ea4e32682 /gnu
parentf5a8d873fb282c67125ba8112305779ef76d24e8 (diff)
downloadguix-7d220b780adeded95710aa46a490bebd2f1994e7.tar.gz
guix-7d220b780adeded95710aa46a490bebd2f1994e7.zip
gnu: font-fontna-yasashisa-antique: Install license file.
* gnu/packages/fonts.scm (font-fontna-yasashisa-antique)[arguments]<#:phases>: Add "enter-license-directory" phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fonts.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 18214174d8..0e89ab8f20 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3114,7 +3114,10 @@ modified to cover most CJK unified ideograph characters.")
;; which makes rename-file fail. Instead, use shell globbing to
;; select and rename the directory.
(invoke "sh" "-c" "mv TrueType* TrueType")
- #t)))))
+ #t))
+ (add-before 'install-license-files 'enter-license-directory
+ (lambda _
+ (chdir "IPAexfont00201"))))))
(native-inputs
`(("bash" ,bash-minimal)
("coreutils" ,coreutils)))