aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-20 22:01:17 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-21 08:28:14 +0000
commit7d199bdc2bcd429b25378478be00c470501f8c3b (patch)
tree3c58414d8f557e6c90cf8857e097a08fcff7d6ca /gnu
parentcf3f3dc056fcc91156ce5117dffd247d229003ba (diff)
downloadguix-7d199bdc2bcd429b25378478be00c470501f8c3b.tar.gz
guix-7d199bdc2bcd429b25378478be00c470501f8c3b.zip
gnu: python-parsley: Fix build.
* gnu/packages/python-xyz.scm (python-parsley): [arguments] <test-flags>: Provide test directories, enable all tests. Change-Id: I164e24ffb24114e4cc548b76df261e3e447ffa08
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 615dcc0b13..0086d06465 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5192,13 +5192,12 @@ syntax.")
(build-system pyproject-build-system)
(arguments
(list
- ;; XXX: Check why these 3 tests fail.
- #:test-flags #~(list "-k"
- (string-append "not test_sending_empty_netstring"
- " and not test_sending_one_netstring"
- " and not test_sending_two_netstrings"))))
- (native-inputs (list python-pytest python-twisted python-setuptools
- python-wheel))
+ #:test-flags #~(list "ometa/test" "terml/test")))
+ (native-inputs
+ (list python-pytest
+ python-twisted
+ python-setuptools
+ python-wheel))
(home-page "https://launchpad.net/parsley")
(synopsis "Parsing and pattern matching Python library")
(description