aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars Bilke <lars.bilke@ufz.de>2024-11-14 15:49:31 +0100
committerLudovic Courtès <ludo@gnu.org>2024-11-18 10:58:42 +0100
commit7c9fcc3e6ee55fdfd35860bd2186eeae90575e3f (patch)
tree553a14aacd8b63d670fad2e2592d0aacdf585399 /gnu
parent299ddd14d8d5ccfd9d0bada8312f9b604399621c (diff)
downloadguix-7c9fcc3e6ee55fdfd35860bd2186eeae90575e3f.tar.gz
guix-7c9fcc3e6ee55fdfd35860bd2186eeae90575e3f.zip
gnu: hdf5: Remove machine info from libraries.
* gnu/packages/maths.scm (hdf5-1.14)[arguments]: Add ‘patch-configure-build-settings’. Change-Id: I1435b866babeb95af48e0fd970d931f022c8bc67 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c5b87d8ff6..62b4f63ac9 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1726,7 +1726,14 @@ extremely large and complex data collections.")
;; modifies the test reference.
(substitute* "test/test_check_version.sh.in"
(("TESTING\\(\\).*" all)
- (string-append all "\nSKIP; exit 0\n")))))))))))
+ (string-append all "\nSKIP; exit 0\n")))))
+ (add-after 'patch-configure 'patch-configure-build-settings
+ (lambda _
+ (substitute* "src/H5build_settings.autotools.c.in"
+ ;; Don't record the build-time kernel version to make the
+ ;; library file reproducible.
+ (("@UNAME_INFO@")
+ "Linux"))))))))))
(define-public hdf5
;; Default version of HDF5.