aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:13:23 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:45 +0200
commit7c702d7e47d588f682040769a02ea6b273c17f8f (patch)
treec9ad7bb836401ac3267b4c83eb032b9cd315fb75 /gnu
parenta6ad5b914c944a3941fdfb356d8af03d23b900b7 (diff)
downloadguix-7c702d7e47d588f682040769a02ea6b273c17f8f.tar.gz
guix-7c702d7e47d588f682040769a02ea6b273c17f8f.zip
gnu: rednotebook: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/rednotebook.scm (rednotebook)[inputs]: Add 'bash-minimal'. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I95d596403bd603df2ef48145bc87f783625b11cf
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rednotebook.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/rednotebook.scm b/gnu/packages/rednotebook.scm
index a67dee07bb..6d61fa1391 100644
--- a/gnu/packages/rednotebook.scm
+++ b/gnu/packages/rednotebook.scm
@@ -22,6 +22,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system python)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages python)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
@@ -70,7 +71,11 @@
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
`("LD_LIBRARY_PATH" ":" prefix (,webkitgtk-path)))))))))
(inputs
- (list gtk+ gtksourceview-3 python-pyyaml python-pygobject
+ (list bash-minimal
+ gtk+
+ gtksourceview-3
+ python-pyyaml
+ python-pygobject
webkitgtk-for-gtk3))
;; TODO: package the following for python3 (if possible), add them as
;; dependencies, and remove them from rednotebook source: