aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-13 17:10:55 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-13 22:49:56 +0200
commit7c2180329eb8ed3612c43761133789a1ee7ac636 (patch)
treeb12ef30c4098d49fadb574c8e3d97ed03d016221 /gnu
parent0f2e91490afed10f3f5414f3806655580a9ce9be (diff)
downloadguix-7c2180329eb8ed3612c43761133789a1ee7ac636.tar.gz
guix-7c2180329eb8ed3612c43761133789a1ee7ac636.zip
gnu: chez-web: Replace texlive-fonts-cm with texlive-cm.
* gnu/packages/chez.scm (chez-web)[native-inputs]: Replace texlive-fonts-cm with texlive-cm in the texlive-union.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/chez.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 350ce4e1f0..2d31d764b0 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -321,9 +321,9 @@ and 32-bit PowerPC architectures.")
texlive-generic-epsf
texlive-metapost
texlive-fonts-charter
- texlive-fonts-cm
texlive-pdftex
texlive-context
+ texlive-cm
texlive-tex-plain)))))
(arguments
`(#:make-flags (list (string-append "PREFIX=" %output)
hen false else # Here '%base-file-systems' appears as if it were a field specified of the # enclosing 'operating-system' form due to parenthesis mismatch. grep "$tmpfile:3:[0-9]\+:.*%base-file-system.*invalid field specifier" \ "$errorfile" fi OS_BASE=' (host-name "antelope") (timezone "Europe/Paris") (locale "en_US.UTF-8") (bootloader (bootloader-configuration (bootloader grub-bootloader) (targets (list "/dev/sdX")))) (file-systems (cons (file-system (device (file-system-label "root")) (mount-point "/") (type "ext4")) %base-file-systems)) ' # Reporting of duplicate service identifiers. cat > "$tmpfile" <<EOF (use-modules (gnu)) (use-service-modules networking) (operating-system $OS_BASE (services (cons* (service dhcp-client-service-type) (service dhcp-client-service-type) ;twice! %base-services))) EOF if guix system vm "$tmpfile" 2> "$errorfile" then # This must not succeed. exit 1 else grep "service 'networking'.*more than once" "$errorfile" fi # Reporting unmet shepherd requirements. cat > "$tmpfile" <<EOF (use-modules (gnu) (gnu services shepherd)) (use-service-modules networking) (define buggy-service-type (shepherd-service-type 'buggy (lambda _ (shepherd-service (provision '(buggy!)) (requirement '(does-not-exist)) (start #t))) (description "Buggy."))) (operating-system $OS_BASE (services (cons (service buggy-service-type #t) %base-services))) EOF if guix system build "$tmpfile" 2> "$errorfile" then exit 1 else grep "service 'buggy!'.*'does-not-exist'.*not provided" "$errorfile" fi # Reporting inconsistent user accounts. make_user_config () { cat > "$tmpfile" <<EOF (use-modules (gnu)) (use-service-modules networking) (operating-system (host-name "antelope") (timezone "Europe/Paris") (locale "en_US.UTF-8") (bootloader (bootloader-configuration (bootloader grub-bootloader) (targets (list "/dev/sdX")))) (file-systems (cons (file-system (device (file-system-label "root")) (mount-point "/") (type "ext4")) %base-file-systems)) (users (list (user-account (name "dave") (home-directory "/home/dave") (group "$1") (supplementary-groups '("$2")))))) EOF } make_user_config "users" "wheel" guix system build "$tmpfile" -n # succeeds guix system build "$tmpfile" -d # succeeds guix system build "$tmpfile" -d | grep '\.drv$' guix system vm "$tmpfile" -d # succeeds guix system vm "$tmpfile" -d | grep '\.drv$' # Make sure the behavior is deterministic (<https://bugs.gnu.org/32652>). drv1="`guix system vm "$tmpfile" -d`" drv2="`guix system vm "$tmpfile" -d`" test "$drv1" = "$drv2" drv1="`guix system image -t iso9660 "$tmpfile" -d`" drv2="`guix system image -t iso9660 "$tmpfile" -d`" test "$drv1" = "$drv2" # Check whether the graph commands work as expected. guix system extension-graph "$tmpfile" | grep 'label = "file-systems"' guix system shepherd-graph "$tmpfile" | grep 'label = "guix-daemon"' make_user_config "group-that-does-not-exist" "users" if guix system build "$tmpfile" -n 2> "$errorfile" then false else grep "primary group.*group-that-does-not-exist.*undeclared" "$errorfile"; fi make_user_config "users" "group-that-does-not-exist" if guix system build "$tmpfile" -n 2> "$errorfile" then false else grep "supplementary group.*group-that-does-not-exist.*undeclared" "$errorfile"; fi # Try 'local-file' and relative file name resolution. cat > "$tmpdir/config.scm"<<EOF (use-modules (gnu)) (use-service-modules networking) (operating-system $OS_BASE (services (cons (service tor-service-type (tor-configuration (config-file (local-file "my-torrc")))) %base-services))) EOF cat > "$tmpdir/my-torrc"<<EOF # This is an example file. EOF # In both cases 'my-torrc' should be properly resolved. guix system build "$tmpdir/config.scm" -n (cd "$tmpdir"; guix system build "config.scm" -n) # Check that we get a warning when passing 'local-file' a non-literal relative # file name. cat > "$tmpdir/config.scm" <<EOF (use-modules (guix)) (define (bad-local-file file) (local-file file)) (bad-local-file "whatever.scm") EOF guix system build "$tmpdir/config.scm" -n && false guix system build "$tmpdir/config.scm" -n 2>&1 | \ grep "config\.scm:4:2: warning:.*whatever.*relative to current directory" # Searching. guix system search tor | grep "^name: tor" guix system search tor | grep "^shepherdnames: tor" guix system search anonym network | grep "^name: tor" guix system search . > "$tmpdir/search" test $(wc -l < "$tmpdir/search") -gt 500 rm "$tmpdir/search" # Below, use -n (--dry-run) for the tests because if we actually tried to # build these images, the commands would take hours to run in the worst case. # Verify that the examples can be built. for example in gnu/system/examples/*.tmpl; do case "$example" in *hurd*) options="--target=i586-pc-gnu";; *asus*) # 'asus-c201.tmpl' uses 'linux-libre-arm-generic', which is an # ARM-only package. options="--system=armhf-linux";; *raspberry*) # The Raspberry Pi templates 'linux-libre-arm64-generic', which is # an ARM-only package. options="--system=aarch64-linux";; *plasma*) # Some architectures do not support all the packages Plasma # depends on so restrict to x86_64-linux. options="--system=x86_64-linux";; *vm-image*) # The VM image tries to build 'current-guix' as per 'guix pull'. # Skip it. continue ;; *desktop*) # This image uses 'grub-efi-bootloader' so it needs a GPT # partition. options="-t efi-raw --system=x86_64-linux";; *) options="" ;; esac guix system -n image $options "$example" done # Make sure the desktop image can be built on major architectures. for system in x86_64-linux aarch64-linux do guix system -n image -s "$system" -t efi-raw \ gnu/system/examples/desktop.tmpl done # Verify that the images can be built. guix system -n vm gnu/system/examples/bare-bones.tmpl guix system -n image gnu/system/images/pinebook-pro.scm guix system -n image -t qcow2 gnu/system/examples/bare-bones.tmpl guix system -n image -t iso9660 gnu/system/examples/bare-bones.tmpl guix system -n docker-image gnu/system/examples/docker-image.tmpl # Verify that at least the raw image type is available. guix system --list-image-types | grep "raw"