aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-03-03 18:48:52 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-03-03 19:04:31 +0200
commit7b3f2682de38a8e39f052705795ec85fcdfc8a96 (patch)
tree9606df3f7f034212c71df1e9fe4bb6b38db14bcc /gnu
parentfd41741bdcfdd1722831cded1d7dc8951fe7fd81 (diff)
downloadguix-7b3f2682de38a8e39f052705795ec85fcdfc8a96.tar.gz
guix-7b3f2682de38a8e39f052705795ec85fcdfc8a96.zip
gnu: irssi: Support proxy, socks, bot.
* gnu/packages/irc.scm (irssi)[arguments]: Add configure flags to support proxy, socks and bot.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/irc.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 6a3da60440..ba5b9e26ae 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -113,7 +113,10 @@ irssi, but graphical.")
(zero?
(system* "./configure"
(string-append "--prefix=" out)
- (string-append "--with-ncurses=" ncurses)))))))))
+ (string-append "--with-ncurses=" ncurses)
+ (string-append "--with-proxy")
+ (string-append "--with-socks")
+ (string-append "--with-bot")))))))))
(inputs
`(("glib" ,glib)
("ncurses" ,ncurses)
services: Add a description and location for each service type....Ludovic Courtès 2017-07-11services: Make error message less scary....Ludovic Courtès 2017-05-03ui: Rename '_' to 'G_'....Ludovic Courtès 2017-04-16services: Service types can now specify a default value for instances....Ludovic Courtès 2017-04-16services: 'service-parameters' becomes 'service-value'....Ludovic Courtès 2017-04-13services: Define '%linux-bare-metal-service' using 'simple-service'....Ludovic Courtès 2017-03-10services: Create /var/log upon activation....Christopher Baines 2017-02-08services: Add 'special-files-service-type'....Ludovic Courtès 2017-01-24services: Create /var/log/wtmp upon activation....Ludovic Courtès 2017-01-19services: Create /var/run/utmpx upon activation....Ludovic Courtès 2017-01-16services: Export 'service-extension' procedures....Christopher Baines 2016-12-11services: Activate system prior to services....Christopher Baines