aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-17 16:14:28 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:32 -0500
commit771550b28042a93ea2a87f2c2c42d72e577170e9 (patch)
tree7538542e63fbf0f1480beb69b7d064d8aa6673b2 /gnu
parent37b589425fa9f5ee6f0c7999e0f2c35c7438b7e4 (diff)
downloadguix-771550b28042a93ea2a87f2c2c42d72e577170e9.tar.gz
guix-771550b28042a93ea2a87f2c2c42d72e577170e9.zip
gnu: cairo: Use bash-minimal unconditionally.
* gnu/packages/gtk.scm (cairo)[inputs]: Use bash-minimal unconditionally.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 781c66192c..dff09bf674 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -188,10 +188,7 @@ tools have full access to view and control running applications.")
("pkg-config" ,pkg-config)
("python" ,python-wrapper)))
(inputs
- ;; TODO(core-updates): make this unconditional
- `(,@(if (%current-target-system)
- `(("bash-minimal" ,bash-minimal)) ; for glib-or-gtk-wrap
- '())
+ `(("bash-minimal" ,bash-minimal)
("drm" ,libdrm)
("ghostscript" ,ghostscript)
("libspectre" ,libspectre)
:06 +0200'>2021-10-31guix home: import: Call ‘local-file’ with ‘name’...Set the name of the file to just the basename of the file passed to ‘local-file’. * guix/scripts/home/import.scm (basename+remove-dots): New procedure. (generate-bash-configuration+modules): Use it. * tests/home-import.scm (match-home-environment-bash-service): Adjust accordingly. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Xinglu Chen 2021-10-31Add tests for ‘guix home import’....* tests/home-import.scm: New file. * Makefile.am (SCM_TESTS): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Xinglu Chen