aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:23:21 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:06 +0200
commit76a18a0cbb4cc4c5af922259843794f07a11f5e6 (patch)
tree2bd56076416de12f40aaaf2365f42504cbb8f3a6 /gnu
parent4ccf99d65be4b3ba74034739385c13f5a6b58d62 (diff)
downloadguix-76a18a0cbb4cc4c5af922259843794f07a11f5e6.tar.gz
guix-76a18a0cbb4cc4c5af922259843794f07a11f5e6.zip
gnu: emacs-ht: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-ht)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a8c671dd4a..60166b6d59 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5949,14 +5949,13 @@ procedures for emacs-lisp-mode.")
(version "2.2")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/Wilfred/ht.el/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Wilfred/ht.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0fsi27gdrh2dgwdbq43vnw5sz25war6shlxaclr60fl7krpxjkzf"))))
+ (base32 "1p3qa7g0wa0wbviv2f8bda39cjys3naayk5xjm3nxxmqsyy8papx"))))
(build-system emacs-build-system)
(propagated-inputs `(("emacs-dash" ,emacs-dash)))
(home-page "https://github.com/Wilfred/ht.el")