aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-09-15 09:20:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-09-15 10:45:39 +0200
commit75f303e0aeeb3b435b4ac5955511819664d41ee1 (patch)
tree5233861097524a22f4e01b7546af00a3c0d9a40d /gnu
parent586651c397f82a34075f43c3b5876d1b3931bf67 (diff)
downloadguix-75f303e0aeeb3b435b4ac5955511819664d41ee1.tar.gz
guix-75f303e0aeeb3b435b4ac5955511819664d41ee1.zip
gnu: emacs-git-gutter: Update to 0.93.
* gnu/packages/emacs-xyz.scm (emacs-git-gutter): Update to 0.93. Change-Id: I3697fbce129190fc88c700477bf35051f214c419
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm38
1 files changed, 18 insertions, 20 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index be069772da..7b3385d968 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6916,32 +6916,30 @@ representation.")
(license license:gpl2+))))
(define-public emacs-git-gutter
- (let ((commit "ec28e85d237065cb3c28db4b66d129da6d309f9c")
- (revision "0"))
- (package
- (name "emacs-git-gutter")
- (version (git-version "0.92" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/syohex/emacs-git-gutter")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1fx3jp65ibcsv8akd8g4k701cs8yq0sg1bd2qszzfh6lvc4pblmi"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/syohex/emacs-git-gutter")
- (synopsis "See and manage hunks of text in a version control system")
- (description
- "This package is an Emacs minor mode for displaying and interacting with
+ (package
+ (name "emacs-git-gutter")
+ (version "0.93")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/syohex/emacs-git-gutter")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qjp1gind95py0zfc3a32j7g6bmdh0pszpyiazqqzxm3rz82m7rn"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/syohex/emacs-git-gutter")
+ (synopsis "See and manage hunks of text in a version control system")
+ (description
+ "This package is an Emacs minor mode for displaying and interacting with
hunks of text managed in a version control system. Added modified and deleted
areas can be indicated with symbols on the edge of the buffer, and commands
can be used to move between and perform actions on these hunks.
Git, Mercurial, Subversion and Bazaar are supported, and many parts of the
display and behaviour is easily customisable.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-git-gutter-fringe
(let ((commit "648cb5b57faec55711803cdc9434e55a733c3eba")
/BOOT/BOOTX64.efi. Grub has explicit support for this location/situation with the `--removable` flag. * gnu/bootloader/grub.scm (install-grub-efi-removable) (grub-efi-removable-bootloader): New variables. * doc/guix.texi (Bootloader Configuration): Document it. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Karl Hallsby