aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:07:26 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:41 +0200
commit75497ecc4aca27078b1b66991b8ef33abfd11845 (patch)
tree8729233e0f2c9746c97a704b45c2db995d1b4219 /gnu
parent65db0c06037aa6da9335a224f7e36161d6ba7153 (diff)
downloadguix-75497ecc4aca27078b1b66991b8ef33abfd11845.tar.gz
guix-75497ecc4aca27078b1b66991b8ef33abfd11845.zip
gnu: 389-ds-base: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/openldap.scm (389-ds-base)[inputs]: Add 'bash-minimal'. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/openldap.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index 3f441f56b4..02c8d825f7 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -28,6 +28,7 @@
(define-module (gnu packages openldap)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages cyrus-sasl)
@@ -319,7 +320,8 @@ servers from Python programs.")
"/bin/ds-logpipe.py"
"/bin/ds-replcheck"))))))))
(inputs
- (list bdb
+ (list bash-minimal
+ bdb
cracklib
cyrus-sasl
gnutls
td>Ludovic Courtès * tests/guix-home.sh: Invoke "guix home reconfigure" a second time with a modify config file and check the result. 2022-03-10tests: Simplify use of 'local-file' in 'tests/guix-home.sh'.Ludovic Courtès * tests/guix-home.sh: Remove 'current-filename' trickery since 'local-file' resolves file names relative to the containing file. 2022-03-10tests: Make sure 'guix home reconfigure' backs up files.Ludovic Courtès * tests/guix-home.sh: Create ~/.bashrc and ~/.config/test.conf prior to 'reconfigure' and check whether they were backed up. 2021-10-09home: services: configuration: Support file-like objects.Oleg Pykhalov * gnu/home/services/configuration.scm (interpose): Operate only with file-like objects. (string-or-gexp?): Delete procedure. (serialize-string-or-gexp): Rename to 'serialize-file-like'. (text-config?): Call 'file-like' intead of 'string-or-gexp?'. * guix/scripts/home/import.scm: (generate-bash-module+configuration): Don't call slurp-file-gexp. * gnu/home/services/configuration.scm: Move content ... * gnu/services/configuration.scm: here. * gnu/home/services/shells.scm: Delete (gnu home services configuration). * gnu/home/services/xdg.scm: Same. * gnu/local.mk: Same. * tests/guix-home.sh: Test home-bash-service-type and extension with home-bash-extension. 2021-10-09tests: Add guix-home.sh.Oleg Pykhalov * tests/guix-home.sh: New file. * Makefile.am (SH_TESTS): Add this.