aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-09-30 12:43:44 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-09-30 17:11:25 +0300
commit730f7c096df36f087a7cf9d289cd0f0bece1a5c2 (patch)
treea6f2374897b98d38a0e91a4eb19dc8bd6d5ea0a4 /gnu
parent9d9b53ed5f79e1d79ab1907faffee1bba0ac422d (diff)
downloadguix-730f7c096df36f087a7cf9d289cd0f0bece1a5c2.tar.gz
guix-730f7c096df36f087a7cf9d289cd0f0bece1a5c2.zip
gnu: rav1e: Force building with rust edition 2018.
* gnu/packages/video.scm (rav1e)[arguments]: Add phase to force all input crates to be built with rust edition 2018.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ca6148b078..6a14a85b74 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -5285,6 +5285,12 @@ result in several formats:
(substitute* "Cargo.toml"
;; Allow using more recent versions of
(("~3.1.2") "~3"))))
+ (add-after 'configure 'force-rust-edition-2018
+ (lambda* (#:key vendor-dir #:allow-other-keys)
+ ;; Force all the dependencies to not be higher than edition 2018.
+ (with-fluids ((%default-port-encoding #f))
+ (substitute* (find-files vendor-dir "Cargo.toml")
+ (("edition = \\\"2021\\\"") "edition = \"2018\"")))))
(replace 'build
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
84e'>file-systems: Ensure compared file names are both absolute or relative....Maxim Cournoyer 2021-06-29pack: Prevent duplicate files in tar archives....Maxim Cournoyer 2021-06-25vm: Update deprecated QEMU option syntax....Tobias Geerinckx-Rice 2021-05-18Revert "vm: Autoload (gnu build vm)."...Tobias Geerinckx-Rice 2021-05-17vm: Remove unused imports....Ludovic Courtès 2021-05-17vm: Autoload (gnu build vm)....Ludovic Courtès 2021-05-10system: vm-image.tmpl: Add a crutch to allow refreshing the resolution....Maxim Cournoyer 2021-05-06gnu: system: Add SPICE capability to the VM image....Maxim Cournoyer 2021-05-04locale: Remove glibc 2.29 from '%default-locale-libcs'....Ludovic Courtès 2021-04-12system: vm: Add a memory-size argument to system-docker-image....Mathieu Othacehe 2021-04-08system: vm: Set a larger value for the msize option of the 9p file system....Maxim Cournoyer 2021-02-25system: vm: Use Guile 3.0 in Docker images....Ludovic Courtès 2021-02-22system: hurd: Have the static networking provision 'networking....Christopher Baines 2021-02-21image: Add rock64 support....Marius Bakke 2021-02-17scripts: system: Accept <image> records as input....Mathieu Othacehe 2021-02-17scripts: system: Remove 'vm-image' command....Mathieu Othacehe 2021-01-20images: pinebook-pro: Fix default serial port....Caliph Nomble 2021-01-20services: Do not warn, when duplicate users are eq?....Leo Prikler 2021-01-20shadow: End duplicate warnings with new lines....Leo Prikler 2021-01-19system: Rename 'disk-image' command 'image'....Mathieu Othacehe 2021-01-17image: Rename "raw" image-type to "efi-raw"....Mathieu Othacehe 2021-01-13services: shepherd: 'shepherd-service-type' requires documentation....Ludovic Courtès 2021-01-13Reapply "system: Assert, that user and group names are unique."...Leo Prikler 2021-01-12Revert "system: Assert, that user and group names are unique."...Jonathan Brielmaier 2021-01-11system: Assert, that user and group names are unique....Leo Prikler 2021-01-10system: image: Fix root offset on rockchip platforms....Mathieu Othacehe 2020-12-15store-copy: 'populate-store' can optionally deduplicate files....Ludovic Courtès 2020-12-11install: Discover local substitute servers....Mathieu Othacehe 2020-12-06linux-initrd: Add bcachefs support....Tobias Geerinckx-Rice 2020-12-05images: novena: Make boot settings and RTC accessible....Danny Milosavljevic 2020-12-04image: Fix ISO image production....Mathieu Othacehe 2020-12-03images: novena: Replace agetty-service by term-auto....Danny Milosavljevic