aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-11-20 14:37:28 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2022-11-21 10:01:03 +0100
commit7245773eb60460e79d3629e7b5e8f93b3748882c (patch)
treecec52f22aa39a4c04077b1f028abca1539ede080 /gnu
parent97bbdedfd316694a2f7ed17d8b31101c27329c80 (diff)
downloadguix-7245773eb60460e79d3629e7b5e8f93b3748882c.tar.gz
guix-7245773eb60460e79d3629e7b5e8f93b3748882c.zip
gnu: Add cl-stealth-mixin.
* gnu/packages/lisp-xyz.scm (sbcl-stealth-mixin, cl-stealth-mixin, ecl-stealth-mixin): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 27312cb369..8610fbaf50 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -23666,6 +23666,38 @@ objects to be mixed and updated without manually defining many permutations.")
(define-public ecl-dynamic-mixins
(sbcl-package->ecl-package sbcl-dynamic-mixins))
+(define-public sbcl-stealth-mixin
+ (let ((commit "2f853fcead554221d4be3b10522b502ea729e944")
+ (revision "0"))
+ (package
+ (name "sbcl-stealth-mixin")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/robert-strandh/Stealth-mixin")
+ (commit commit)))
+ (file-name (git-file-name "cl-stealth-mixin" version))
+ (sha256
+ (base32 "0ar9cdmbmdnqz1ywpw34n47hlh0vqmb6pl76f5vbfgip3c81xwyi"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-closer-mop))
+ (home-page "https://github.com/robert-strandh/Stealth-mixin")
+ (synopsis "Create stealth mixin classes")
+ (description
+ "Stealth-mixin is a Common Lisp library for creating stealth mixin
+classes. These are classes that are dynamically mixed into other classes
+without the latter being aware of it.")
+ (license license:bsd-2))))
+
+(define-public cl-stealth-mixin
+ (sbcl-package->cl-source-package sbcl-stealth-mixin))
+
+(define-public ecl-stealth-mixin
+ (sbcl-package->ecl-package sbcl-stealth-mixin))
+
(define-public sbcl-sealable-metaobjects
(let ((commit "e09ec97252e0844528f61abdc0c7ee256875f8ee"))
(package