aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-22 10:54:23 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:00 +0300
commit69f7147312c95445eed82fc64e49e3e22258666f (patch)
tree74e82a8fd6c7780648cbf69c52ec535f6c6e93ba /gnu
parent2a1a0e440c938362c3d37289c008db5a227d87a8 (diff)
downloadguix-69f7147312c95445eed82fc64e49e3e22258666f.tar.gz
guix-69f7147312c95445eed82fc64e49e3e22258666f.zip
gnu: Add rust-ghash-0.5.
* gnu/packages/crates-io.scm (rust-ghash-0.5): New variable. (rust-ghash-0.3): Inherit from rust-ghash-0.5.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm32
1 files changed, 26 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9f04953a9e..df0efe8502 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -24270,25 +24270,25 @@ getters and setters on fields.")
@acronym{GFA, Graphical Fragment Assembly} format.")
(license license:expat)))
-(define-public rust-ghash-0.3
+(define-public rust-ghash-0.5
(package
(name "rust-ghash")
- (version "0.3.0")
+ (version "0.5.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "ghash" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "0c957q9sk1q93pqqfvhcmflfm1zvbr14aznfpm25kqd6i437zqnn"))))
+ (base32 "0h1y3v3kj8xxkf2snv1yly0lr20fdh3jrm60p382szbiwl6pac6r"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
- (("rust-polyval" ,rust-polyval-0.4)
+ (("rust-opaque-debug" ,rust-opaque-debug-0.3)
+ ("rust-polyval" ,rust-polyval-0.6)
("rust-zeroize" ,rust-zeroize-1))
#:cargo-development-inputs
- (("rust-hex-literal" ,rust-hex-literal-0.1))))
+ (("rust-hex-literal" ,rust-hex-literal-0.3))))
(home-page "https://github.com/RustCrypto/universal-hashes")
(synopsis "Universal hash over GF(2^128)")
(description "This package provides a universal hash over GF(2^128) useful
@@ -24296,6 +24296,26 @@ for constructing a Message Authentication Code (MAC), as in the AES-GCM
authenticated encryption cipher.")
(license (list license:expat license:asl2.0))))
+(define-public rust-ghash-0.3
+ (package
+ (inherit rust-ghash-0.5)
+ (name "rust-ghash")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ghash" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0c957q9sk1q93pqqfvhcmflfm1zvbr14aznfpm25kqd6i437zqnn"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-polyval" ,rust-polyval-0.4)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs
+ (("rust-hex-literal" ,rust-hex-literal-0.1))))))
+
(define-public rust-ghash-0.2
(package
(inherit rust-ghash-0.3)