aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-09-09 21:03:25 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-09-09 21:03:50 +0800
commit694cd39fa1a7920b64ee7295560741c4069ca651 (patch)
treeda114ead6210c24736a314d41b68c84d9c61380d /gnu
parented6ca2c4136e2f584aefb9378b3e1cddf58fe553 (diff)
downloadguix-694cd39fa1a7920b64ee7295560741c4069ca651.tar.gz
guix-694cd39fa1a7920b64ee7295560741c4069ca651.zip
gnu: reprotest: Use G-expression.
* gnu/packages/diffoscope.scm (reprotest)[arguments]: Use G-expression. Change-Id: I35d4673e39a449169f5a66265e486d8e45268425
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/diffoscope.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 4f00f5759d..7eb1a24c84 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -279,20 +279,20 @@ install.")
xxd))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((mandir1 (string-append
- (assoc-ref outputs "out") "/share/man/man1"))
- (docdir (string-append
- (assoc-ref outputs "out") "/share/doc/" ,name "-" ,version)))
- (invoke "make" "-C" "doc")
- (mkdir-p mandir1)
- (install-file "doc/reprotest.1" mandir1)
- (mkdir-p docdir)
- (install-file "./README.rst" docdir)
- (install-file "./README-dev.rst" docdir)))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda _
+ (let* ((mandir1 (string-append
+ #$output "/share/man/man1"))
+ (docdir (string-append
+ #$output "/share/doc/" #$name "-" #$version)))
+ (invoke "make" "-C" "doc")
+ (mkdir-p mandir1)
+ (install-file "doc/reprotest.1" mandir1)
+ (mkdir-p docdir)
+ (install-file "./README.rst" docdir)
+ (install-file "./README-dev.rst" docdir)))))))
(home-page "https://salsa.debian.org/reproducible-builds/reprotest")
(synopsis "Build software and check it for reproducibility")
(description "Reprotest builds the same source code twice in different