aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-28 23:49:04 +0000
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-12-01 10:27:40 +0300
commit689d2ac36c56c1573cd7418efe7676988f118024 (patch)
treeb39cde276ff7e225ce989e2e22a04cc1bbb528ff /gnu
parent9874cc55817c9147fc55ad4b938914b7b836004c (diff)
downloadguix-689d2ac36c56c1573cd7418efe7676988f118024.tar.gz
guix-689d2ac36c56c1573cd7418efe7676988f118024.zip
gnu: Add go-github-com-charmbracelet-bubbles.
* gnu/packages/golang-xyz.scm (go-github-com-charmbracelet-bubbles): New variable. Change-Id: I090db91509590ca9a8cab1a209d00bcc12b524e7 Reviewed-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e7979387e3..db11b2b542 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1582,6 +1582,43 @@ tools.")
(modify-inputs (package-propagated-inputs go-github-com-cheggaaa-pb)
(append go-github-com-vividcortex-ewma)))))
+(define-public go-github-com-charmbracelet-bubbles
+ (package
+ (name "go-github-com-charmbracelet-bubbles")
+ (version "0.20.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/charmbracelet/bubbles")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qdcln01bq9lk6r33b8p5d5x850wgd8ddq57n4bg3xn76z2fd657"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/charmbracelet/bubbles"))
+ (propagated-inputs
+ (list go-github-com-atotto-clipboard
+ go-github-com-charmbracelet-bubbletea
+ go-github-com-charmbracelet-harmonica
+ go-github-com-charmbracelet-lipgloss
+ go-github-com-charmbracelet-x-ansi
+ go-github-com-charmbracelet-x-exp-golden
+ go-github-com-dustin-go-humanize
+ go-github-com-lucasb-eyer-go-colorful
+ go-github-com-makenowjust-heredoc
+ go-github-com-mattn-go-runewidth
+ go-github-com-muesli-termenv
+ go-github-com-rivo-uniseg
+ go-github-com-sahilm-fuzzy))
+ (home-page "https://github.com/charmbracelet/bubbles")
+ (synopsis "TUI components for Bubble Tea library")
+ (description
+ "@code{bubbles} is a library that provide components for
+@@url{https://github.com/charmbracelet/bubbletea, Bubble Tea} applications.")
+ (license license:expat)))
+
(define-public go-github-com-charmbracelet-lipgloss
(package
(name "go-github-com-charmbracelet-lipgloss")
ages/aux-files/linux-libre/6.10-arm64.conf, gnu/packages/aux-files/linux-libre/6.10-i686.conf, gnu/packages/aux-files/linux-libre/6.10-x86.conf: New files. * Makefile.am (AUX_FILES): Add them. Change-Id: If62ec2e8029ebd7531d3b4ba9a666c0b5f3b0f4c Signed-off-by: Leo Famulari <leo@famulari.name> Wilko Meyer 2024-07-07gnu: emacs-next: Update to 30.0.60-1.4e22ef8....* gnu/packages/aux-files/emacs/comp-integrity-next.el: New file. * Makefile.am (AUX_FILES): Register it here. * gnu/packages/emacs.scm (emacs-next-minimal): Update to 30.0.60-1.4e22ef8. (emacs->emacs-next)[arguments]: Swap out ‘validate-comp-integrity’ phase, so as to refer to the new integrity check. Liliana Marie Prikler 2024-06-17gnu: Remove linux-libre 6.8....* gnu/packages/linux.scm (linux-libre-6.8-version, linux-libre-6.8-gnu-revision, deblob-scripts-6.8, linux-libre-6.8-pristine-source, linux-libre-6.8-source, linux-libre-headers-6.8, linux-libre-6.8): Remove variables. * gnu/packages/aux-files/linux-libre/6.8-arm.conf, gnu/packages/aux-files/linux-libre/6.8-arm64.conf, gnu/packages/aux-files/linux-libre/6.8-riscv.conf gnu/packages/aux-files/linux-libre/6.8-i686.conf, gnu/packages/aux-files/linux-libre/6.8-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove aforementioned .conf files. Signed-off-by: Leo Famulari <leo@famulari.name> Change-Id: Ib94c61f629721f94a307e51b449e5ccd117a2f9a Wilko Meyer 2024-06-06gnu: linux-libre: Add 6.9-riscv.conf...* gnu/packages/aux-files/linux-libre/6.9-riscv.conf: New file. * Makefile.am (AUX_FILES): Register it. Change-Id: I1f5e24726c3a59bec73805068548ce5916b427f8 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Zheng Junjie 2024-05-26gnu: Add linux-libre 6.9....Big thanks to Dariqq <dariqq@posteo.net> for debugging and communicating upstream about a problem with the deblobbing scripts in this kernel series! * gnu/packages/linux.scm (linux-libre-6.9-version, linux-libre-6.9-gnu-revision, deblob-scripts-6.9, linux-libre-6.9-pristine-source, linux-libre-6.9-source, linux-libre-headers-6.9, linux-libre-6.9): New variables. * gnu/packages/aux-files/linux-libre/6.9-arm.conf, gnu/packages/aux-files/linux-libre/6.9-arm64.conf, gnu/packages/aux-files/linux-libre/6.9-i686.conf, gnu/packages/aux-files/linux-libre/6.9-x86.conf: New files. * Makefile.am (AUX_FILES): Add them. Signed-off-by: Leo Famulari <leo@famulari.name> Change-Id: I8dc011a603684f0be88766b7881aa6c560b94443 Wilko Meyer 2024-05-22gnu: linux-libre-6.8: Add riscv config....* gnu/packages/aux-files/linux-libre/6.8-riscv.conf: New files. * Makefile.am (AUX_FILES): Add it. Change-Id: I293912d4f7fe09e281432b0f973999d9d8db582a Zheng Junjie 2024-04-30gnu: Remove linux-libre 6.7....* gnu/packages/linux.scm (linux-libre-6.7-version, linux-libre-6.7-gnu-revision, deblob-scripts-6.7, linux-libre-6.7-pristine-source, linux-libre-6.7-source, linux-libre-headers-6.7, linux-libre-6.7): Remove variables. * gnu/packages/aux-files/linux-libre/6.7-arm.conf, gnu/packages/aux-files/linux-libre/6.7-arm64.conf, gnu/packages/aux-files/linux-libre/6.7-i686.conf, gnu/packages/aux-files/linux-libre/6.7-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove aforementioned .conf files. Change-Id: Ic69a65e1fbfa59d893e85d26950f33195ea9fbe1 Signed-off-by: Leo Famulari <leo@famulari.name> Wilko Meyer 2024-03-27Merge branch 'master' into emacs-teamLiliana Marie Prikler 2024-03-22gnu: Add linux-libre 6.8....* gnu/packages/linux.scm (linux-libre-6.8-version, linux-libre-6.8-gnu-revision, deblob-scripts-6.8, linux-libre-6.8-pristine-source, linux-libre-6.8-source, linux-libre-headers-6.8, linux-libre-6.8): New variables. * gnu/packages/aux-files/linux-libre/6.8-arm.conf, gnu/packages/aux-files/linux-libre/6.8-arm64.conf, gnu/packages/aux-files/linux-libre/6.8-i686.conf, gnu/packages/aux-files/linux-libre/6.8-x86.conf: New files. * Makefile.am (AUX_FILES): Add them. Signed-off-by: Leo Famulari <leo@famulari.name> Change-Id: I338eb725e0b991c67e4d98bd1ef0c441d3d8f0c6 Wilko Meyer 2024-03-22gnu: emacs: Only verify integrity of bound symbols....Some variants, like emacs-no-x, come with a reduced set of preloaded symbols, so don't expect them to always be native. * gnu/packages/aux-files/emacs/comp-integrity.el (expect-native-if-bound): New function. (x-setup-function-keys, dynamic-setting-handle-config-changed-event) (fontset-plain-name, fringe-mode, image-type, regexp-opt, scroll-bar-scale): Use ‘expect-native-if-bound’. (x-handle-no-bitmap-icon): Likewise, was already conditional. Liliana Marie Prikler 2024-03-04aux-files: comp-integrity: Adjust for emacs-pgtk....* gnu/packages/aux-files/emacs/comp-integrity.el (x-dnd-init-frame): Require x-dnd. (x-handle-no-bitmap-icon): Only test this if it's bound. Liliana Marie Prikler 2024-03-02gnu: emacs-next-minimal: Update to 30.0.50-2.170c655....* gnu/packages/emacs.scm (emacs-next-minimal): Update to 30.0.50-2.170c655. * gnu/packages/aux-files/emacs/comp-integrity.el: Adjust accordingly. Liliana Marie Prikler 2024-03-02Merge branch 'master' into emacs-teamLiliana Marie Prikler 2024-02-25gnu: renpy: Update to 8.2.0....* gnu/packages/aux-files/renpy/renpy.in (path-to-saves): Honour RENPY_PATH_TO_SAVES. (path_to_logdir, predefined_searchpath): New procedures. * gnu/packages/game-development.scm (python-renpy): Update to 8.2.0. Liliana Marie Prikler 2024-02-24gnu: emacs: Check integrity of native-compiled files....In the previous commit, we've added a patch that potentially messes with how built-in (especially preloaded) Lisp libraries are loaded. Thus, we might want to assert that these files still load fine, as reported when querying the builtin documentation of functions provided by them. * gnu/packages/aux-files/emacs/comp-integrity.el: New file. * gnu/Makefile.am (dist_noinst_DATA): Register it here. * gnu/packages/emacs.scm (emacs-no-x)[#:phases]: Add ‘validate-comp-integrity’. Liliana Marie Prikler 2024-02-20gnu: linux-libre 6.7: Modify .conf files....* gnu/packages/aux-files/linux-libre/6.7-arm.conf, gnu/packages/aux-files/linux-libre/6.7-arm64.conf: Add platform support. Change-Id: I90dee088ab11a31cb526b396d675e7bc22d67297 Signed-off-by: Leo Famulari <leo@famulari.name> Wilko Meyer 2024-01-22gnu: Remove linux-libre 4.14....* gnu/packages/linux.scm (linux-libre-4.14-version, linux-libre-4.14-gnu-revision, deblob-scripts-4.14, linux-libre-4.14-pristine-source, linux-libre-4.14-source, linux-libre-headers-4.14, linux-libre-4.14, linux-libre-arm-generic-4.14, linux-libre-arm-omap2plus-4.14): Remove variables. * gnu/packages/aux-files/linux-libre/4.14-arm.conf, gnu/packages/aux-files/linux-libre/4.14-i686.conf, gnu/packages/aux-files/linux-libre/4.14-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove aforementioned .conf files. * gnu/tests/base.scm (%test-linux-libre-4.14): Remove variable. Change-Id: I40393b5f46b989848d569c929f1d9c986736553e Wilko Meyer 2024-01-17gnu: Add linux-libre 6.7....* gnu/packages/linux.scm (linux-libre-6.7-version, linux-libre-6.7-gnu-revision, deblob-scripts-6.7, linux-libre-6.7-pristine-source, linux-libre-6.7-source, linux-libre-headers-6.7, linux-libre-6.7): New variables. * gnu/packages/aux-files/linux-libre/6.7-arm.conf, gnu/packages/aux-files/linux-libre/6.7-arm64.conf, gnu/packages/aux-files/linux-libre/6.7-i686.conf, gnu/packages/aux-files/linux-libre/6.7-x86.conf: New files. * Makefile.am (AUX_FILES): Add them. * Makefile.am: Update my copyright header. Change-Id: I88b633933875f64bd2859774419e077d8f36d75b Signed-off-by: Leo Famulari <leo@famulari.name> Wilko Meyer