aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-01-16 18:38:18 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:50 +0200
commit6747d4bdb58a8008feaea16bbc7a4b599b038a52 (patch)
treefef6791906333aab123086ce283b77e0dc5cadd1 /gnu
parent88874db03e6f138ff73df31222d51a6893c62c1f (diff)
downloadguix-6747d4bdb58a8008feaea16bbc7a4b599b038a52.tar.gz
guix-6747d4bdb58a8008feaea16bbc7a4b599b038a52.zip
gnu: volume-key: Add required transitive dependencies.
* gnu/packages/disk.scm (volume-key): Add transitive dependencies for libdevmapper and libcryptsetup. Change-Id: Iaced5bedd2f6ec8e67118b2ee4d01f14704a3694
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/disk.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 357920af9c..d92c0ebe15 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -1039,12 +1039,13 @@ and its highly optimized now for efficient performance.")
(native-inputs
(list pkg-config swig python-3)) ; used to generate the Python bindings
(inputs
- `(("cryptsetup" ,cryptsetup)
- ("nss" ,nss)
- ("libblkid" ,util-linux "lib")
- ("lvm2" ,lvm2) ; for "-ldevmapper"
- ("glib" ,glib)
- ("gpgme" ,gpgme)))
+ (append
+ (cons cryptsetup (libcryptsetup-propagated-inputs))
+ (cons lvm2 (libdevmapper-propagated-inputs))
+ (list nss
+ (list util-linux "lib")
+ glib
+ gpgme)))
(arguments
`(#:tests? #f ; not sure how tests are supposed to pass, even when run manually
#:phases