aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:08 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:19 -0500
commit66ea5eebb192dd144d44b0520166e9b095f8ac8b (patch)
treeeb95b46ec23c8f6e7e9df554d2b75a59c98cb3d6 /gnu
parent584bff22f27436c095a56560865cae05b31fbd84 (diff)
downloadguix-66ea5eebb192dd144d44b0520166e9b095f8ac8b.tar.gz
guix-66ea5eebb192dd144d44b0520166e9b095f8ac8b.zip
gnu: go-github-com-coreos-go-oidc: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-coreos-go-oidc): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: Iadefbc9c3df2aa291a3eb4c8cc31a5fdf562e138
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm27
-rw-r--r--gnu/packages/golang.scm27
2 files changed, 27 insertions, 27 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 976179f44e..792406ab97 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -182,6 +182,33 @@ the parse trees produced by the html package.")
(description "This package provides a CSS parser and inliner.")
(license license:expat)))
+(define-public go-github-com-coreos-go-oidc
+ (package
+ (name "go-github-com-coreos-go-oidc")
+ (version "2.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/coreos/go-oidc")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "11m6slbpi33ynffml7812piq4anhjlf1qszjlsf26f5y7x3qh8n5"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/coreos/go-oidc"))
+ (propagated-inputs
+ (list go-github-com-pquerna-cachecontrol
+ go-golang-org-x-oauth2
+ go-gopkg-in-square-go-jose-v2))
+ (home-page "https://github.com/coreos/go-oidc")
+ (synopsis "OpenID Connect support for Go")
+ (description
+ "This package enables OpenID Connect support for the
+@code{go-golang-org-x-oauth2} package.")
+ (license license:asl2.0)))
+
(define-public go-github-com-felixge-httpsnoop
(package
(name "go-github-com-felixge-httpsnoop")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f222b40ead..f67b38f34e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9379,33 +9379,6 @@ templates on ANSI compatible terminals. You can create your own stylesheet or
use one of our glamorous default themes.")
(license license:expat)))
-(define-public go-github-com-coreos-go-oidc
- (package
- (name "go-github-com-coreos-go-oidc")
- (version "2.2.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/coreos/go-oidc")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "11m6slbpi33ynffml7812piq4anhjlf1qszjlsf26f5y7x3qh8n5"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "github.com/coreos/go-oidc"))
- (propagated-inputs
- (list go-github-com-pquerna-cachecontrol
- go-golang-org-x-oauth2
- go-gopkg-in-square-go-jose-v2))
- (home-page "https://github.com/coreos/go-oidc")
- (synopsis "OpenID Connect support for Go")
- (description
- "This package enables OpenID Connect support for the
-@code{go-golang-org-x-oauth2} package.")
- (license license:asl2.0)))
-
(define-public go-github-com-coreos-go-oidc-v3
(package
(inherit go-github-com-coreos-go-oidc)