aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSören Tempel <soeren@soeren-tempel.net>2024-07-27 11:10:54 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-07-27 17:53:01 +0200
commit661d5eeb8e1eed7b564b62d6b8d104d013e8860b (patch)
treef01f8380068f7ecef5ef065e6bfaae340a81a323 /gnu
parent0acc1c68d68b75f76e77896c70ed7533b3ba5cd7 (diff)
downloadguix-661d5eeb8e1eed7b564b62d6b8d104d013e8860b.tar.gz
guix-661d5eeb8e1eed7b564b62d6b8d104d013e8860b.zip
gnu: klee: Wrap klee-stats for Python dependencies.
* gnu/packages/check.scm (klee): Wrap klee-stats. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 412b94569c..347bd2e1aa 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1070,12 +1070,17 @@ with the @code{klee} package.")
(substitute* "CMakeLists.txt"
(("\\$\\{KLEE_UCLIBC_PATH\\}/lib/libc\\.a")
"${KLEE_UCLIBC_PATH}"))))
- (add-after 'install 'wrap-hooks
+ (add-after 'install 'wrap-programs
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
(lib (string-append out "/lib")))
- ;; Ensure that KLEE finds runtime libraries (e.g. uclibc).
+ ;; Ensure that klee-stats finds its Python dependencies.
+ (wrap-program (string-append bin "/klee-stats")
+ `("GUIX_PYTHONPATH" ":" prefix
+ ,(search-path-as-string->list
+ (getenv "GUIX_PYTHONPATH"))))
+ ;; Ensure that klee finds runtime libraries (e.g. uclibc).
(wrap-program (string-append bin "/klee")
`("KLEE_RUNTIME_LIBRARY_PATH" =
(,(string-append lib "/klee/runtime/"))))))))
@@ -1088,7 +1093,7 @@ with the @code{klee} package.")
(search-input-file %build-inputs "/lib/klee/libc.a"))
"-DENABLE_POSIX_RUNTIME=ON")))
(native-inputs (list clang-13 llvm-13 python-lit))
- (inputs (list bash-minimal klee-uclibc gperftools sqlite z3))
+ (inputs (list bash-minimal klee-uclibc gperftools sqlite z3 python python-tabulate))
(build-system cmake-build-system)
(home-page "https://klee-se.org/")
(synopsis "Symbolic execution engine")