aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 18:50:00 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:06 +0300
commit63e6c4ad99bb2ddcd40d79d003775dde98d19bc6 (patch)
treef5d935bcbf00655db4b29ef809b944626d3cdb4b /gnu
parent59dc661fc63b44aa20b290cf67146fceef724554 (diff)
downloadguix-63e6c4ad99bb2ddcd40d79d003775dde98d19bc6.tar.gz
guix-63e6c4ad99bb2ddcd40d79d003775dde98d19bc6.zip
gnu: Add emacs-makey.
* gnu/packages/emacs.scm (emacs-makey): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3585387d75..440ff18abf 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8091,3 +8091,23 @@ the source file.")
(description "@url{https://www.reddit.com} backend for the Gnus
newsreader.")
(license license:gpl3+))))
+
+(define-public emacs-makey
+ (package
+ (name "emacs-makey")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mickeynp/makey/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0kzl4q1wf2zhkx9nrymxa67n99iq0bj7zqhpaz4byksna1hsxfmv"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/mickeynp/makey")
+ (synopsis "Emacs interactive command-line mode")
+ (description
+ "This package provides an Emacs interactive command-line mode.")
+ (license license:gpl3+)))