aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-13 00:48:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-13 01:19:53 +0200
commit63c8323ae9b9cf9cd9684a65bfacc05077c65583 (patch)
treea1e64eea10a55d991ff45107899371d9fc3c38ba /gnu
parent43fb14cedcf563824064f1d04240f0bbc68f267f (diff)
downloadguix-63c8323ae9b9cf9cd9684a65bfacc05077c65583.tar.gz
guix-63c8323ae9b9cf9cd9684a65bfacc05077c65583.zip
gnu: r-clusterprofiler: Update to 3.16.0.
* gnu/packages/bioconductor.scm (r-clusterprofiler): Update to 3.16.0. [propagated-inputs]: Remove r-ggplot2; add r-downloader and r-dplyr. [native-inputs]: Add r-knitr.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index dc4d1572ac..ffc72b1453 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3810,22 +3810,23 @@ All the visualization methods are developed based on ggplot2 graphics.")
(define-public r-clusterprofiler
(package
(name "r-clusterprofiler")
- (version "3.14.3")
+ (version "3.16.0")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "clusterProfiler" version))
(sha256
(base32
- "08pd7bmqmyxncj09ilz8yb9sf1pv9ni98y8b93pz2giy7pl407hg"))))
+ "0m7919gzrd2fddb4kcznwpshhab1ha2yppnkxg11zmh40wcdawyi"))))
(properties
`((upstream-name . "clusterProfiler")))
(build-system r-build-system)
(propagated-inputs
`(("r-annotationdbi" ,r-annotationdbi)
("r-dose" ,r-dose)
+ ("r-downloader" ,r-downloader)
+ ("r-dplyr" ,r-dplyr)
("r-enrichplot" ,r-enrichplot)
- ("r-ggplot2" ,r-ggplot2)
("r-go-db" ,r-go-db)
("r-gosemsim" ,r-gosemsim)
("r-magrittr" ,r-magrittr)
@@ -3833,6 +3834,8 @@ All the visualization methods are developed based on ggplot2 graphics.")
("r-qvalue" ,r-qvalue)
("r-rvcheck" ,r-rvcheck)
("r-tidyr" ,r-tidyr)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://guangchuangyu.github.io/software/clusterProfiler/")
(synopsis "Analysis and visualization of functional profiles for gene clusters")
(description
olspan='3' class='logmsg'> This is a follow-up of c311147bd16aa0e5746d9cbf31502f5fd61e470c. * gnu/tests/databases.scm (run-postgresql-test): Use "/tmp" as database host. 2021-03-16gnu: Remove MongoDB.Léo Le Bouter mongodb 3.4.10 has unpatched CVEs and mongodb 3.4.24 has some files in the release tarball under the SSPL, therefore we cannot provide mongodb while upholding to good security standards. It turns out feff80cec3c97a3df2c20d300be12d67f79d4f22 was right since while the main license file wasnt altered to SSPL, some files in the tree contain SSPL headers. * gnu/packages/databases.scm (go-gopkg.in-mgo.v2): Remove. * gnu/packages/databases.scm (mongo-tools): Remove. * doc/guix.texi (mongodb-service-type): Remove. * gnu/tests/databases.scm (%test-mongodb, %mongodb-os, run-mongodb-test): Remove. * gnu/services/databases.scm (mongodb-configuration, mongodb-configuration?, mongodb-configuration-mongodb, mongodb-configuration-config-file, mongodb-configuration-data-directory, mongodb-service-type, %default-mongodb-configuration-file, %mongodb-accounts, mongodb-activation, mongodb-shepherd-service): Remove. * gnu/packages/databases.scm (mongodb): Remove. 2021-01-28services: postgresql: Add postgresql-role-service-type.Mathieu Othacehe * gnu/services/databases.scm (postgresql-role, postgresql-role?, postgresql-role-name, postgresql-role-permissions, postgresql-role-create-database?, postgresql-role-configuration, postgresql-role-configuration?, postgresql-role-configuration-host, postgresql-role-configuration-roles, postgresql-role-service-type): New procedures. * gnu/tests/databases.scm: Test it. * doc/guix.texi: Document it. 2021-01-28services: postgresql: Add log directory support.Mathieu Othacehe * gnu/services/databases.scm (postgresql-configuration-log-directory): New procedure. (<postgresql-configuration>)[log-directory]: New field. (postgresql-activation): Create the log directory. (postgresql-shepherd-service): Honor it. * gnu/tests/databases.scm (%postgresql-log-directory): New variable. (log-file): New test case. * doc/guix.texi (Database Services): Document it. 2021-01-28services: postgresql: Use Guile datatypes.Mathieu Othacehe * gnu/services/databases.scm (postgresql-config-file-compiler): Support Guile datatypes in the "extra-config" field. * gnu/tests/databases.scm (%postgresql-os): Test it. * doc/guix.texi (Database Services): Document it. 2020-11-28services: MySQL: Add more tests.Marius Bakke * gnu/tests/databases.scm (run-mysql-test): Try creating a database and inserting data. 2020-11-28services: MySQL: Upgrade database schemas automatically.Marius Bakke * gnu/services/databases.scm (<mysql-configuration>): Add AUTO-UPGRADE? field. (mysql-upgrade-wrapper, mysql-upgrade-shepherd-service, mysql-shepherd-services): New variables. (mysql-service-type): Use MYSQL-SHEPHERD-SERVICES instead of MYSQL-SHEPHERD-SERVICE. * doc/guix.texi (Database Services): Document the AUTO-UPGRADE? field of MYSQL-SERVICE-TYPE. * gnu/tests/databases.scm (run-mysql-test): Test that mysql_upgrade has run. 2020-11-28services: MySQL: Deprecate 'mysql-service'.Marius Bakke * gnu/services/databases.scm (mysql-service): Define in terms of DEFINE-DEPRECATED. * gnu/tests/databases.scm (%mysql-os): Adjust accordingly. * doc/guix.texi (Database Services): Adjust the MariaDB/MySQL section to document MYSQL-SERVICE-TYPE instead of MYSQL-SERVICE. While at it, document the EXTRA-CONTENT field. 2020-10-20services: databases: Don't specify a default postgresql version.Christopher Baines Currently, if the postgresql package major version changes, this is going to break the service upon upgrade, because PostgreSQL will reject the data files from the differing major version of the service. Because it's important to either keep running a particular major version, or intentionally upgrade, I think the configuration would be better with no default. I think this is also going to be helpful when trying to assist users upgrading PostgreSQL. * gnu/services/databases.scm (<postgresql-configuration>): Remove default for postgresql. (postgresql-service-type): Remove the default value. * gnu/tests/databases.scm (%postgresql-os): Update accordingly. * gnu/tests/guix.scm (%guix-data-service-os): Update accordingly. * gnu/tests/monitoring.scm (%zabbix-os): Update accordingly. * gnu/tests/web.scm (patchwork-os): Update accordingly. * doc/guix.texi (PostgreSQL): Update accordingly.