aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-02 18:48:30 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-02 21:46:36 +0100
commit631ea9a411b36214813851fecab9ab919f30c5f1 (patch)
treef4b5b9daa011958adb9c965db98f94c3079af125 /gnu
parenta268b1ba91f95ec5ac84813310cc7a3e934d00da (diff)
downloadguix-631ea9a411b36214813851fecab9ab919f30c5f1.tar.gz
guix-631ea9a411b36214813851fecab9ab919f30c5f1.zip
gnu: python-pybedtools: Use pyproject-build-system.
* gnu/packages/bioinformatics.scm (python-pybedtools)[build-system]: Use pyproject-build-system. [arguments]: Import (guix build pyproject-build-system).
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 413f6dfdff..d9da6f690d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -914,11 +914,12 @@ servers supporting the protocol.")
(sha256
(base32
"18rhzk08d3rpxhi5xh6pqg64x6v5q3daw6y3v54k85v4swncjrwj"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
`(#:modules ((srfi srfi-26)
(guix build utils)
- (guix build python-build-system))
+ (guix build python-build-system)
+ (guix build pyproject-build-system))
;; See https://github.com/daler/pybedtools/issues/192
#:phases
(modify-phases %standard-phases
@@ -978,7 +979,7 @@ which are widely used for genomic interval manipulation or \"genome algebra\".
pybedtools extends BEDTools by offering feature-level manipulations from with
Python.")
;; pypi lists GPLv2 in the PKG-INFO and website, but was relicensed in
- ;; version 0.9.0 and the LICENSE.txt is consistant with the source code.
+ ;; version 0.9.0 and the LICENSE.txt is consistent with the source code.
;;
;; pybedtools/include/gzstream.cpp and pybedtools/include/gzstream.h are
;; licensed lgpl2.1+