aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 22:55:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:15 +0200
commit606f33421d4d481cbdc6013599a1354a5ea6aa3b (patch)
tree7eeb3831d03a6a3b5ae65cdbbe47cd0223d94efe /gnu
parent2ff9e2eadc18bd4447d8c346e303f5a43fb59a24 (diff)
downloadguix-606f33421d4d481cbdc6013599a1354a5ea6aa3b.tar.gz
guix-606f33421d4d481cbdc6013599a1354a5ea6aa3b.zip
gnu: texlive-inputenx: Refresh package definition.
* gnu/packages/tex.scm (texlive-inputenx): Remove SIMPLE-TEXLIVE-PACKAGE call.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 15 insertions, 13 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 35161f56c0..cd3b5fd22f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3066,21 +3066,23 @@ UCY (Omega Unicode Cyrillic), LCY, LWN (OT2), and koi8-r.")
(define-public texlive-inputenx
(package
- (inherit (simple-texlive-package
- "texlive-inputenx"
- (list "doc/latex/inputenx/"
- "tex/latex/inputenx/"
- "source/latex/inputenx/")
- (base32
- "0snjndrcynm4w8m9iq8gmadzhrbwvsdy4y1ak24ia0hpsicdi4aj")
- #:trivial? #t))
- (home-page "https://ctan.org/macros/latex/contrib/inputenx")
+ (name "texlive-inputenx")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/inputenx/" "source/latex/inputenx/"
+ "tex/latex/inputenx/")
+ (base32
+ "0snjndrcynm4w8m9iq8gmadzhrbwvsdy4y1ak24ia0hpsicdi4aj")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/inputenx")
(synopsis "Enhanced input encoding handling")
(description
- "This package deals with input encodings. It provides a wider range of input
-encodings using standard mappings, than does inputenc. It also covers nearly all
-slots. In this way, it serves as more up to date replacement for the inputenc
-package.")
+ "This package deals with input encodings. It provides a wider range of
+input encodings using standard mappings, than does @code{inputenc}. It also
+covers nearly all slots. In this way, it serves as more up to date
+replacement for the @code{inputenc} package.")
(license license:lppl1.3+)))
(define-public texlive-kpathsea