aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-12-03 14:51:01 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-12-05 06:20:48 +0100
commit5d9bb65ec28fb34d1d29b4df19cd478db4e5bc1e (patch)
treee57c1174fc27679669e2f529e61fe5c72f693e1f /gnu
parent83e03f9380ab5a8a07f2473ee7eafecc729be3c2 (diff)
downloadguix-5d9bb65ec28fb34d1d29b4df19cd478db4e5bc1e.tar.gz
guix-5d9bb65ec28fb34d1d29b4df19cd478db4e5bc1e.zip
gnu: Add xdg-desktop-portal-gnome.
* gnu/packages/gnome.scm (xdg-desktop-portal-gnome): New variable. Change-Id: I2925cf950b731c71e4ad4a01f28bce22c0cb54fb Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1eee97c2dd..d10c3c8a9b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12863,6 +12863,44 @@ provided there is a DBus service present:
(simple-service 'ratbagd dbus-root-service-type (list libratbag))")
(license license:gpl2)))
+(define-public xdg-desktop-portal-gnome
+ (package
+ (name "xdg-desktop-portal-gnome")
+ (version "44.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "08gznmr718na5p2j8fm7nim5862r2v0sjh68ql5yl0q356n1mvah"))
+ (snippet
+ #~(begin
+ (use-modules (guix build utils))
+ (delete-file-recursively "subprojects")))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:glib-or-gtk? #t
+ #:configure-flags #~'("-Dsystemduserunitdir=no")))
+ (inputs
+ (list gnome-desktop
+ gsettings-desktop-schemas
+ libadwaita
+ libxml2
+ xdg-desktop-portal
+ xdg-desktop-portal-gtk))
+ (native-inputs
+ (list gettext-minimal
+ `(,glib "bin")
+ pkg-config))
+ (home-page "https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome")
+ (synopsis "GNOME backend for xdg-desktop-portal")
+ (description "xdg-desktop-portal-gnome implements a back-end for
+@command{xdg-desktop-portal} that uses gtk and some more GNOME APIs.")
+ (license license:lgpl2.1+)))
+
(define-public parlatype
(package
(name "parlatype")