aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:02:03 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:10:39 +0100
commit5d1809a08a0bf048341aff3d6a6e4234bd607dca (patch)
tree90ddb55794c00b90c29228e4564fdd0fb30f45e5 /gnu
parentd2ea723f8eda3e6e57ca75be4f57c31dec18a6fc (diff)
downloadguix-5d1809a08a0bf048341aff3d6a6e4234bd607dca.tar.gz
guix-5d1809a08a0bf048341aff3d6a6e4234bd607dca.zip
gnu: Remove ocaml4.07-ppx-sexp-value.
* gnu/packages/ocaml.scm (ocaml4.07-ppx-sexp-value): Remove variable. (ocaml-ppx-sexp-value)[properties]: Remove variant. Change-Id: Ib5b777b78c63d9cbc4812affba6f861c89ff3cce
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 1 insertions, 24 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0c0a1d1765..d961bb7ec7 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7117,36 +7117,13 @@ many values).")
(build-system dune-build-system)
(propagated-inputs
(list ocaml-base ocaml-ppx-here ocaml-ppx-sexp-conv ocaml-ppxlib))
- (properties `((upstream-name . "ppx_sexp_value")
- (ocaml4.07-variant . ,(delay ocaml4.07-ppx-sexp-value))))
+ (properties `((upstream-name . "ppx_sexp_value")))
(home-page "https://github.com/janestreet/ppx_sexp_value")
(synopsis "Simplify building s-expressions from ocaml values")
(description "@samp{ppx-sexp-value} is a ppx rewriter that simplifies
building s-expressions from ocaml values.")
(license license:expat)))
-(define-public ocaml4.07-ppx-sexp-value
- (package-with-ocaml4.07
- (package
- (inherit ocaml-ppx-sexp-value)
- (version "0.11.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
- (version-major+minor version)
- "/files/ppx_sexp_value-v" version ".tar.gz"))
- (sha256
- (base32
- "1xnalfrln6k5khsyxvxkg6v32q8fpr4cqamsjqfih29jdv486xrs"))))
- (propagated-inputs
- (list ocaml-base
- ocaml-ppx-here
- ocaml-ppx-sexp-conv
- ocaml-migrate-parsetree
- ocaml-ppxlib))
- (properties '())
- (license license:asl2.0))))
-
(define-public ocaml-ppx-sexp-message
(package
(name "ocaml-ppx-sexp-message")