aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-11-25 16:17:33 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-03 08:26:03 +0100
commit5cb84f2013c5b1e48a7d0e617032266f1e6059e2 (patch)
tree86c752e8ca1ee8144c82afb7894cb5d90916cf98 /gnu
parent2c700af42cbb17859a7d80807fef2000cab7f8ad (diff)
downloadguix-5cb84f2013c5b1e48a7d0e617032266f1e6059e2.tar.gz
guix-5cb84f2013c5b1e48a7d0e617032266f1e6059e2.zip
system: Add "installer" sub-command.
* guix/scripts/system/installer.scm: New file. * Makefile.am (MODULES)[ENABLE_INSTALLER]: Register it. (MODULES_NOT_COMPILED)[!ENABLE_INSTALLER]: Likewise. * guix/scripts/system.scm (show-help): Add help for "installer" sub-command. (actions): Register "installer". (guix-system): Invoke `guix-system-installer' sub-command. * doc/guix.texi (Invoking guix system): Document it. * gnu/installer.scm (run-installer): Remove "./pre-inst env". Change-Id: I5a05b941c060682c17d45d871df3cf34e3f8643a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/installer.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/installer.scm b/gnu/installer.scm
index 0a36f1f67b..4acad60f21 100644
--- a/gnu/installer.scm
+++ b/gnu/installer.scm
@@ -642,4 +642,4 @@ and PARTITION pages are skipped."
(outputs (build-derivations store (list drv))))
(close-connection store)
(format #t "running installer: ~a\n" program)
- (invoke "./pre-inst-env" "guile" program)))
+ (invoke "guile" program)))