aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-20 01:15:35 -0400
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:31 +0200
commit57976f87c7f4498d48474cd910dc5d0fc18dc2dd (patch)
treeb2f833e69264d07135ffc6f9d116334fccadf863 /gnu
parent08ee4ea24bc3eac16d228073b86d78062e372e26 (diff)
downloadguix-57976f87c7f4498d48474cd910dc5d0fc18dc2dd.tar.gz
guix-57976f87c7f4498d48474cd910dc5d0fc18dc2dd.zip
gnu: cups-filters: Add bash-minimal to inputs.
* gnu/packages/cups.scm (cups-filters) [inputs]: Add bash-minimal. Change-Id: Ie6059967d41bbf83fa7d51ea34db269e57b76af5
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cups.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 96933db00d..0ba7b70c3f 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -214,6 +214,7 @@ driver is known to work with these printers:
pkg-config)))
(inputs
(list avahi
+ bash-minimal
coreutils
cups-minimal
dbus
ed, 4 insertions, 3 deletions
diff --git a/src/hydrilla/builder/build.py b/src/hydrilla/builder/build.py
index 58fe1b2..2824e9b 100644
--- a/src/hydrilla/builder/build.py
+++ b/src/hydrilla/builder/build.py
@@ -253,9 +253,10 @@ class Build:
Return a minimal item reference suitable for using in source
description.
"""
- copy_props = ['type', 'identifier', 'long_name', 'uuid', 'description']
- if 'comment' in item_def:
- copy_props.append('comment')
+ copy_props = ['type', 'identifier', 'long_name', 'description']
+ for prop in ('comment', 'uuid'):
+ if prop in item_def:
+ copy_props.append(prop)
if item_def['type'] == 'resource':
item_list = self.resource_list
diff --git a/src/hydrilla/schemas b/src/hydrilla/schemas
-Subproject 1d1c93d5a9011ecdf58a4952afcb5a1faff30e7
+Subproject 5ef63e81ddd7299bfb738cae643bc48560b68a1