aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:06:31 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:34 +0200
commit57383740c9dcb529e7fbaee8eb6ee15ac6c5150d (patch)
treeed8a7af824d28ee4e784c93e2abd6aa4dd119e1b /gnu
parent2abc77996eff8963e6decaf75cae7775b4044ed4 (diff)
downloadguix-57383740c9dcb529e7fbaee8eb6ee15ac6c5150d.tar.gz
guix-57383740c9dcb529e7fbaee8eb6ee15ac6c5150d.zip
gnu: tryton: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/tryton.scm (tryton): Remove trailing #t. [inputs]: New field. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I9c8b7b2ad4445fe6d2f02f85c04ab3fb099aa476
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index f5d193cc6f..7f62e2d339 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -23,6 +23,7 @@
(define-module (gnu packages tryton)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages check)
#:use-module (gnu packages databases)
#:use-module (gnu packages finance)
@@ -123,11 +124,11 @@ and security.")
(let ((out (assoc-ref outputs "out"))
(gi-typelib-path (getenv "GI_TYPELIB_PATH")))
(wrap-program (string-append out "/bin/tryton")
- `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
- #t)))))
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))))))))
(native-inputs
- `(("glib-compile-schemas" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)))
+ (list `(,glib "bin")
+ gobject-introspection))
+ (inputs (list bash-minimal)) ;for wrap-program
(propagated-inputs
(list (librsvg-for-system)
gsettings-desktop-schemas