aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-03 19:35:40 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:37 +0000
commit56f663870fc712500f249e19b559316c10320fcb (patch)
tree09a67cf7d4c89a832dc5787091bad86fc40bbb55 /gnu
parente4fcdc52bb056354cc08fb9b9be5dd8e4236b26d (diff)
downloadguix-56f663870fc712500f249e19b559316c10320fcb.tar.gz
guix-56f663870fc712500f249e19b559316c10320fcb.zip
gnu: go-github-com-lithammer-fuzzysearch: Move to golang-xyz.
gnu/packages/golang.scm (go-github-com-lithammer-fuzzysearch): Move from here ... gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ica80efe706f97694f5f6584fe64f9a764e5d082b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm34
-rw-r--r--gnu/packages/golang.scm34
2 files changed, 34 insertions, 34 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c8db6ae479..04f6f6bb9a 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4329,6 +4329,40 @@ allocator. This is primarily useful for long lived buffers that usually sit emp
length-delimited slices. It's helpful for building wire protocols.")
(license license:expat)))
+(define-public go-github-com-lithammer-fuzzysearch
+ (package
+ (name "go-github-com-lithammer-fuzzysearch")
+ (version "1.1.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lithammer/fuzzysearch")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0fp00gzbrr5fnz01lmkjqcs5z24zjrsp4r13ia0x0wslp5r13hv8"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/lithammer/fuzzysearch"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Replace when go-build-system supports nested path.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key import-path tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
+ (propagated-inputs (list go-golang-org-x-text))
+ (home-page "https://github.com/lithammer/fuzzysearch")
+ (synopsis "Tiny and fast fuzzy search in Go")
+ (description
+ "A speedy fuzzy matching package for Go inspired by the JavaScript
+library bevacqua/fuzzysearch.")
+ (license license:expat)))
+
(define-public go-github-com-liyue201-gostl
(package
(name "go-github-com-liyue201-gostl")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f0753d97ed..bb72caae27 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8234,40 +8234,6 @@ useful during debugging, to avoid wrapping long output lines in the
terminal.")
(license license:expat)))
-(define-public go-github-com-lithammer-fuzzysearch
- (package
- (name "go-github-com-lithammer-fuzzysearch")
- (version "1.1.8")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/lithammer/fuzzysearch")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0fp00gzbrr5fnz01lmkjqcs5z24zjrsp4r13ia0x0wslp5r13hv8"))))
- (build-system go-build-system)
- (propagated-inputs (list go-golang-org-x-text))
- (arguments
- (list
- #:import-path "github.com/lithammer/fuzzysearch"
- #:phases
- #~(modify-phases %standard-phases
- ;; XXX: Replace when go-build-system supports nested path.
- (delete 'build)
- (replace 'check
- (lambda* (#:key import-path tests? #:allow-other-keys)
- (when tests?
- (with-directory-excursion (string-append "src/" import-path)
- (invoke "go" "test" "-v" "./..."))))))))
- (home-page "https://github.com/lithammer/fuzzysearch")
- (synopsis "Tiny and fast fuzzy search in Go")
- (description
- "A speedy fuzzy matching package for Go inspired by the JavaScript
-library bevacqua/fuzzysearch.")
- (license license:expat)))
-
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar