aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndrew Wong <wongandj@icloud.com>2025-01-05 05:17:27 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2025-01-26 21:16:55 +0100
commit55859a28cc1deeddb2d7e46c3a4579290029501b (patch)
tree1ecaa39ff1d767f47a5f8263b53ddd662a8305db /gnu
parentcbc6baf5e9084b78770b1adeb063c11a842a1a64 (diff)
downloadguix-55859a28cc1deeddb2d7e46c3a4579290029501b.tar.gz
guix-55859a28cc1deeddb2d7e46c3a4579290029501b.zip
gnu: Add swayimg.
* gnu/packages/image-viewers.scm (swayimg): New variable. Change-Id: I5e6d2d01278d34df412a128a67e2ead46ad5afc2 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image-viewers.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 8edfea8bba..904f275d35 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -117,6 +117,55 @@
#:use-module (gnu packages xorg)
#:use-module (gnu packages))
+(define-public swayimg
+ (package
+ (name "swayimg")
+ (version "3.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artemsen/swayimg")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "15nqb1igikkvrzx3dhyj9msynfpvrnqvql6plqm8fhg10fbimfhd"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags '(,(string-append "-Dversion=" version))))
+ (native-inputs (list pkg-config))
+ (inputs (list bash-completion
+ fontconfig
+ freetype
+ giflib
+ ijg-libjpeg
+ imath
+ json-c
+ libavif
+ libexif
+ libheif
+ libjxl
+ libpng
+ librsvg
+ libtiff
+ libwebp
+ libxkbcommon
+ openexr
+ wayland
+ wayland-protocols))
+ (home-page "https://github.com/artemsen/swayimg")
+ (synopsis "Customizable and lightweight image viewer for Wayland")
+ (description
+ "Swayimg is a fully customizable and lightweight image viewer for Wayland
+based display servers. It supports the most popular image formats (JPEG, JPEG
+XL, PNG, GIF, SVG, WebP, HEIF/AVIF, AV1F/AVIFS, TIFF, EXR, BMP, PNM, TGA, QOI,
+DICOM, Farbfeld). It has fully customizable keyboard bindings, colors, and
+many other parameters. It also supports loading images from files and pipes,
+and provides gallery and viewer modes with slideshow and animation support.
+It also includes a Sway integration mode: the application creates an overlay
+above the currently active window, which gives the illusion that you are
+opening the image directly in a terminal window.")
+ (license license:expat)))
+
(define-public ytfzf
(package
(name "ytfzf")