aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2023-12-02 01:28:55 +0100
committerLudovic Courtès <ludo@gnu.org>2023-12-06 23:50:05 +0100
commit5582bd941306678c450226bc02baa54ad4a9412c (patch)
tree25f6da348f767438e8e6b81d1481d664dd3d1ba5 /gnu
parentfb2bbb0c3e9734006a4108a5c4f9901dbf15edae (diff)
downloadguix-5582bd941306678c450226bc02baa54ad4a9412c.tar.gz
guix-5582bd941306678c450226bc02baa54ad4a9412c.zip
gnu: deluge: Update to 2.1.1.
Dependency on nss-certs was added. Most torrents do require SSL in some shape or form, so it seems appropriate to add it by default. * gnu/packages/bittorrent.scm (deluge)[version]: Update to 2.1.1. [propagated-inputs]: Add nss-certs. [native-search-paths]: Set to allow locating the certificates. Change-Id: Ic6c79f24851d6917dc4e5b22b3bcb2f6b99e187a Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bittorrent.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index e115c13017..3d79a3a159 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -46,11 +46,13 @@
#:use-module ((guix licenses) #:prefix l:)
#:use-module (guix gexp)
#:use-module (guix utils)
+ #:use-module ((guix search-paths) #:select ($SSL_CERT_DIR $SSL_CERT_FILE))
#:use-module (gnu packages)
#:use-module (gnu packages adns)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages certs)
#:use-module (gnu packages check)
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
@@ -574,7 +576,7 @@ the following features:
(define-public deluge
(package
(name "deluge")
- (version "2.0.5")
+ (version "2.1.1")
(source
(origin
(method url-fetch)
@@ -583,12 +585,13 @@ the following features:
(version-major+minor version) "/deluge-" version ".tar.xz"))
(sha256
(base32
- "1n15dzfnz1gvb4cf046yhi404i3gs933qgz0ichna6r1znmh9gf4"))))
+ "1xyz8bscwqmd7d8b43svxl42w54pnisvwkkrndx46hifh0cx73bn"))))
(build-system python-build-system)
(inputs (list bash-minimal))
(propagated-inputs
(list gtk+
libtorrent-rasterbar
+ nss-certs
python-pycairo
python-chardet
python-dbus
@@ -606,6 +609,9 @@ the following features:
(native-inputs
(list intltool python-wheel
(librsvg-for-system)))
+ (native-search-paths
+ (list $SSL_CERT_DIR
+ $SSL_CERT_FILE))
;; TODO: Enable tests.
;; After "pytest-twisted" is packaged, HOME is set, and an X server is
;; started, some of the tests still fail. There are likely some tests