aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul Alesius <paul@unnservice.com>2023-02-08 14:27:48 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:11:33 -0400
commit5347378f8a99d5de08061e7db760c678f8571a2f (patch)
tree828168e1a90e693dc570f7d9e4cd7645f6342a89 /gnu
parentc1ef157ff591a42e734c003f2bfc96652a3dc3fe (diff)
downloadguix-5347378f8a99d5de08061e7db760c678f8571a2f.tar.gz
guix-5347378f8a99d5de08061e7db760c678f8571a2f.zip
gnu: Add rust-rustfix-0.6.
* gnu/packages/crates-io.scm (rust-rustfix-0.6): New variable. (rust-rustfix-0.5): Inherit from rust-rustfix-0.6. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Co-authored-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm27
1 files changed, 21 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9711e40b9c..a4be5d5dbd 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -49272,8 +49272,28 @@ rustc compiler.")
"This package provides a tool to manipulate rustdoc comments.")
(license license:asl2.0)))
+(define-public rust-rustfix-0.6
+ (package
+ (name "rust-rustfix")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rustfix" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0apkjxv3z70vhnyz2kpwsivvndk6qk7kkp0rf7sg8pk7q1gy02vg"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/rust-lang/rustfix")
+ (synopsis "Automatically apply the suggestions made by rustc")
+ (description "Automatically apply the suggestions made by rustc.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-rustfix-0.5
(package
+ (inherit rust-rustfix-0.6)
(name "rust-rustfix")
(version "0.5.1")
(source
@@ -49299,12 +49319,7 @@ rustc compiler.")
("rust-env-logger" ,rust-env-logger-0.6)
("rust-log" ,rust-log-0.4)
("rust-proptest" ,rust-proptest-0.9)
- ("rust-tempdir" ,rust-tempdir-0.3))))
- (home-page "https://github.com/rust-lang/rustfix")
- (synopsis "Automatically apply the suggestions made by rustc")
- (description
- "Automatically apply the suggestions made by rustc.")
- (license (list license:expat license:asl2.0))))
+ ("rust-tempdir" ,rust-tempdir-0.3))))))
(define-public rust-rustfix-0.4
(package/inherit rust-rustfix-0.5