aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRemco van 't Veer <remco@remworks.net>2022-09-18 16:21:07 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-09-30 15:48:39 +0200
commit51ab8b855361db7f9a13621d4099dfc6e736ff1f (patch)
treeedd51c243130f8f3dedcb7f7253f54632deb44a2 /gnu
parenta47a051e3d8669c51071f224661e0f7a9c5a9aaa (diff)
downloadguix-51ab8b855361db7f9a13621d4099dfc6e736ff1f.tar.gz
guix-51ab8b855361db7f9a13621d4099dfc6e736ff1f.zip
gnu: quodlibet: Fix build.
Some tests fail because adwaita-icon-theme doesn't ship legacy icons anymore since version 42. Application runs fine without visual defects. * gnu/packages/music.scm (quodlibet): Skip trayicon tests. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 60dccd9b38..6b37c79389 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -6789,7 +6789,9 @@ streaming audio server.")
"--ignore=tests/test_browsers_iradio.py"
;; broken upstream
"--disable-warnings"
- "--ignore=tests/quality")
+ "--ignore=tests/quality"
+ ;; missing legacy icons in adwaita-icon-theme
+ "--ignore=tests/plugin/test_trayicon.py")
(format #t "test suite not run~%"))))
(add-after 'install 'glib-or-gtk-wrap ; ensure icons loaded
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
ansformations.scm (transform-package-patches): New procedure. (%transformations): Add it as 'with-patch'. (%transformation-options, show-transformation-options-help/detailed): Add '--with-patch'. * tests/transformations.scm ("options->transformation, with-patch"): New test. * doc/guix.texi (Package Transformation Options): Document it. Ludovic Courtès 2020-12-21tests: Check the effect of '--without-tests' on implicit inputs....* tests/transformations.scm ("options->transformation, without-tests"): Ensure TAR has #:tests? #f. Ludovic Courtès 2020-10-31guix build: Move transformation options to (guix transformations)....* guix/transformations.scm: New file. * tests/scripts-build.scm: Rename to... * tests/transformations.scm: ... this. * Makefile.am (MODULES): Add 'guix/transformations.scm'. (SCM_TESTS): Adjust to rename. * guix/scripts/build.scm (numeric-extension?) (tarball-base-name, <downloaded-file>, download-to-store*) (compile-downloaded-file, package-with-source) (transform-package-source, evaluate-replacement-specs) (transform-package-inputs, transform-package-inputs/graft) (%not-equal, package-git-url, evaluate-git-replacement-specs) (transform-package-source-branch, transform-package-source-commit) (transform-package-source-git-url, package-dependents/spec) (package-toolchain-rewriting, transform-package-toolchain) (transform-package-with-debug-info, transform-package-tests) (%transformations, transformation-procedure, %transformation-options) (show-transformation-options-help, options->transformation) (package-transformations): Move to (guix transformations). * guix/scripts/environment.scm: Adjust accordingly. * guix/scripts/graph.scm: Likewise. * guix/scripts/install.scm: Likewise. * guix/scripts/pack.scm: Likewise. * guix/scripts/package.scm: Likewise. * guix/scripts/upgrade.scm: Likewise. * po/guix/POTFILES.in: Add 'guix/transformations.scm'. Ludovic Courtès