aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorWojtek Kosior <koszko@koszko.org>2023-12-19 19:56:59 +0100
committerW. Kosior <koszko@koszko.org>2024-09-04 21:02:05 +0200
commit4f9ccf41a6236e64018b73de5c8172ca1ba4461c (patch)
treedd39b234b31b8da4e0586fa17e3e52614159747e /gnu
parent147a942a53addb94eaaecdc7535b8d0ee8bbd563 (diff)
downloadguix-4f9ccf41a6236e64018b73de5c8172ca1ba4461c.tar.gz
guix-4f9ccf41a6236e64018b73de5c8172ca1ba4461c.zip
gnu: exim: Set `exim` as the default user.
* gnu/packages/mail.scm (exim)[arguments]<#:phases>['configure]: Configure Exim to resolve uid/gid of `exim` in runtime and prevent install script from failing. Change-Id: I2571d6e5a4d4aca534ed6bdfaa3832b1ec69c1d5
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index ac9e02a6f6..3fe593a01c 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2014,7 +2014,7 @@ delivery.")
(("(CONFIGURE_FILE=).*" all var)
(string-append var out "/etc/exim.conf\n"))
(("(EXIM_USER=).*" all var)
- (string-append var "nobody\n"))
+ (string-append var "ref:exim\n"))
(("(FIXED_NEVER_USERS=).*" all var)
(string-append var "\n")) ; no root in build environment
(("(COMPRESS_COMMAND=).*" all var)
@@ -2031,6 +2031,13 @@ delivery.")
(("# (AUTH_PLAINTEXT=yes)" all line) line)
(("# (AUTH_SPA=yes)" all line) line)
(("# (AUTH_TLS=yes)" all line) line))
+ ;; The installation script calls Exim once to get its
+ ;; version number. Exim then fails to find the `exim`
+ ;; user and exits with non-zero status.
+ (substitute* "scripts/exim_install"
+ (("(\\$exim 2>/dev/null)" all var)
+ (string-append
+ "printf 'Exim version " #$version " #1'")))
;; This file has hard-coded relative file names for tools
;; despite the zcat configuration above.
(substitute* "src/exigrep.src"