aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-03-14 23:50:53 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-16 15:50:29 +0100
commit4ec1589a43cec5350e651e96d61aa125bd9bdcb9 (patch)
treebb4a2f97e9493bfdcf3652c204846176887ce8af /gnu
parentdf6edddc5c6561b2e52111e380d6f9cf3b6ac523 (diff)
downloadguix-4ec1589a43cec5350e651e96d61aa125bd9bdcb9.tar.gz
guix-4ec1589a43cec5350e651e96d61aa125bd9bdcb9.zip
gnu: Add cl-promise.
* gnu/packages/lisp-xyz.scm (cl-promise, ecl-promise, sbcl-promise): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 5787b1bf7c..abd2ed4c01 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -13022,6 +13022,42 @@ Streams in ICDE’05.")
(define-public ecl-prometheus
(sbcl-package->ecl-package sbcl-prometheus))
+(define-public sbcl-promise
+ (let ((commit "801db8f853da7935ae2e487fd7f8763acbc5ad2a")
+ (revision "0"))
+ (package
+ (name "sbcl-promise")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/promise")
+ (commit commit)))
+ (file-name (git-file-name "cl-promise" version))
+ (sha256
+ (base32 "07cvz6vb5y1d9vndcwq7q1cp54aqvyqzv6wk8vmymbz3lawq2wsn"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-parachute))
+ (inputs
+ (list sbcl-documentation-utils))
+ (home-page "https://shinmera.github.io/promise/")
+ (synopsis "Promise mechanism for asynchronous operations")
+ (description
+ "This library implements a basic promise datastructure, which is useful
+for dealing with asynchronous behaviours. Importantly, this library does not
+use any other libraries or frameworks, and instead leaves the execution and
+state transition of promise objects in your control, making it easy to
+integrate.")
+ (license license:zlib))))
+
+(define-public ecl-promise
+ (sbcl-package->ecl-package sbcl-promise))
+
+(define-public cl-promise
+ (sbcl-package->cl-source-package sbcl-promise))
+
(define-public sbcl-uuid
(let ((commit "e7d6680c3138385c0708f7aaf0c96622eeb140e8"))
(package