aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish.is@lostca.se>2024-07-24 09:17:18 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-08-20 10:51:18 +0200
commit4cff02aa60aabf47eb34da0f4f313c9793d0caa2 (patch)
treed874aab8a85ab77d8cd786b4ccbd4c80e6f7087a /gnu
parent91b69f154db218834de002dcd013a8f47170e684 (diff)
downloadguix-4cff02aa60aabf47eb34da0f4f313c9793d0caa2.tar.gz
guix-4cff02aa60aabf47eb34da0f4f313c9793d0caa2.zip
gnu: Add sshguard.
* gnu/packages/admin.scm (sshguard): New variable. Change-Id: I551771ff49af3e852322f2518f0758494aaedee3 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 73d1b68855..5b6467dd05 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -6349,3 +6349,26 @@ versions of @command{find}, including POSIX, GNU, and *BSD find.")
their content instead of their file names. It is useful for compressing
backup directories or just finding duplicate files.")
(license license:gpl2+)))
+
+(define-public sshguard
+ (package
+ (name "sshguard")
+ (version "2.4.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://bitbucket.org/sshguard/sshguard")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "1dkijr287zpwdz1bjdchxzmwf1sk6vzpkycz1skm25lkaba6nd9r"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list autoconf automake bison flex python-docutils))
+ (home-page "https://sshguard.net/")
+ (synopsis "Daemon to blocks SSH brute-force attacks")
+ (description
+ "SSHGuard protects hosts from brute-force attacks against SSH and other
+services. It aggregates system logs and blocks repeat offenders using one of
+several firewall backends.")
+ (license license:isc)))