aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-20 12:58:47 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-20 14:22:36 -0500
commit4cb5426ccf1ae4baaa7762591776ab773a1047ab (patch)
tree5abeb9dc2811c2948dd38327b8e686b171a067b1 /gnu
parent3044f7249c21f56ace8abed1f50cb37feeeb1808 (diff)
downloadguix-4cb5426ccf1ae4baaa7762591776ab773a1047ab.tar.gz
guix-4cb5426ccf1ae4baaa7762591776ab773a1047ab.zip
gnu: Add Catalyst-Plugin-Static-Simple.
* gnu/packages/web.scm (perl-catalyst-plugin-static-simple): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 8611826710..ddaef2b9ec 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -743,6 +743,36 @@ formats.")
management in web applications together: the state, and the store.")
(license (package-license perl))))
+(define-public perl-catalyst-plugin-static-simple
+ (package
+ (name "perl-catalyst-plugin-static-simple")
+ (version "0.33")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/J/JJ/JJNAPIORK/"
+ "Catalyst-Plugin-Static-Simple-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1h8f12bhzh0ssq9gs8r9g3hqn8zn2k0q944vc1vm8j81bns16msy"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-catalyst-runtime" ,perl-catalyst-runtime)
+ ("perl-mime-types" ,perl-mime-types)
+ ("perl-moose" ,perl-moose)
+ ("perl-moosex-types" ,perl-moosex-types)
+ ("perl-namespace-autoclean" ,perl-namespace-autoclean)))
+ (home-page "http://search.cpan.org/dist/Catalyst-Plugin-Static-Simple")
+ (synopsis "Simple serving of static pages")
+ (description "The Static::Simple plugin is designed to make serving static
+content in your application during development quick and easy, without
+requiring a single line of code from you. This plugin detects static files by
+looking at the file extension in the URL (such as .css or .png or .js). The
+plugin uses the lightweight MIME::Types module to map file extensions to
+IANA-registered MIME types, and will serve your static files with the correct
+MIME type directly to the browser, without being processed through Catalyst.")
+ (license (package-license perl))))
+
(define-public perl-catalyst-runtime
(package
(name "perl-catalyst-runtime")