aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-07-18 00:01:27 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-07-18 17:31:40 +0300
commit4b9cb5f87c77e576c7873cdfba7df324b8d29b55 (patch)
treed642b457b3d7da6b63ac0b10635b101f95aa1d56 /gnu
parentc3cdb2b4057a2c2e8e7be1e320784431f0f671ae (diff)
downloadguix-4b9cb5f87c77e576c7873cdfba7df324b8d29b55.tar.gz
guix-4b9cb5f87c77e576c7873cdfba7df324b8d29b55.zip
gnu: edk2-tools: Limit supported systems.
* gnu/packages/firmware.scm (edk2-tools)[supported-systems]: New field. Change-Id: I1b8a63221b361ec440783c7d93ae120b53cabe2b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/firmware.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 0ed6609c26..7908e1a3fc 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -882,6 +882,9 @@ Executables included are:
@item @code{VfrCompile}: Parse preprocessed UEFI and Framework VFR files.
@item @code{VolInfo}: Display the contents of a firmware volume.
@end itemize")
+ ;; See BaseTools/Source/C/GNUmakefile
+ (supported-systems '("x86_64-linux" "i686-linux" "armhf-linux"
+ "aarch64-linux" "riscv64-linux"))
(license license:bsd-2)))
(define* (make-ovmf-firmware arch)