aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2022-10-17 22:38:15 -0300
committerChristopher Baines <mail@cbaines.net>2022-10-18 10:58:48 +0100
commit4acc8a901918ac9378b66b762fbc82e5e76d9438 (patch)
treeac759ac0a6fba598f9f8ad40c1fe4ea7fc25828b /gnu
parent2a531bfb3445d723bfb915576e266f2094936aef (diff)
downloadguix-4acc8a901918ac9378b66b762fbc82e5e76d9438.tar.gz
guix-4acc8a901918ac9378b66b762fbc82e5e76d9438.zip
gnu: Add perl-ppix-regexp.
* gnu/packages/perl.scm (perl-ppix-regexp): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 31b2abde48..e3e78785a2 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8786,6 +8786,30 @@ applications.")
code.")
(license license:perl-license)))
+(define-public perl-ppix-regexp
+ (package
+ (name "perl-ppix-regexp")
+ (version "0.085")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/W/WY/WYANT/PPIx-Regexp-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "07fg63ql3f7hv1ys10l8j0p562ndraq9lk66iw9y0f444j4vpw1f"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-module-build))
+ (propagated-inputs (list perl-ppi))
+ (home-page "https://metacpan.org/release/PPIx-Regexp")
+ (synopsis "Parse Perl string literals and string-literal-like things")
+ (description
+ "The purpose of the @code{PPIx-Regexp} package is to parse
+regular expressions in a manner similar to the way the @code{PPI} package parses
+Perl. This class forms the root of the parse tree, playing a role similar to
+@code{PPI::Document}.")
+ (license license:perl-license)))
+
(define-public perl-probe-perl
(package
(name "perl-probe-perl")
>2016-09-14gnu: perl-gd: Disable tests.Jan Nieuwenhuizen 2016-07-29gnu: gd: Add fix for gd2_read test.Mark H Weaver 2016-07-29Revert "gnu: gd: Add fix for gd2_read test."Mark H Weaver 2016-07-29gnu: gd: Add fix for gd2_read test.Mark H Weaver 2016-07-29gnu: gd: Update to 2.2.3 [fixes CVE-2016-6207].Mark H Weaver 2016-07-28Revert "gnu: gd: Update to 2.2.3 [fixes CVE-2016-6207]."Leo Famulari 2016-07-28gnu: gd: Update to 2.2.3 [fixes CVE-2016-6207].Mark H Weaver 2016-07-18gnu: gd: Fix failing test on i686.Mark H Weaver 2016-07-16gnu: gd: Fix CVE-2016-{5766,6128,6132,6214}.Leo Famulari 2016-07-16gnu: gd: Update to 2.2.2 [fixes CVE-2016-{5767,6161}].Leo Famulari 2016-05-27gnu: gd: Update to 2.2.1 [fixes CVE-2015-{8874, 8877}].Leo Famulari 2016-05-17gnu: gd: Fix-CVE-2016-3074.Leo Famulari 2016-05-17gnu: gd: Specify 'cpe-name'.Ludovic Courtès 2016-04-14gnu: packages: Use 'search-patches' everywhere.Alex Kost