aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-03 22:42:54 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:12 +0200
commit4a3f50e36c09e18e10be894141ea996fcae1aa52 (patch)
treebe56ddf43dd6683af58c989ebf5c61a6803082cb /gnu
parentfa9c33dc8e012316f3dc3d4d6d0aa7e6cd7df70d (diff)
downloadguix-4a3f50e36c09e18e10be894141ea996fcae1aa52.tar.gz
guix-4a3f50e36c09e18e10be894141ea996fcae1aa52.zip
gnu: ghc-chell-quickcheck: Allow newer QuickCheck.
* gnu/packages/haskell.scm (ghc-chell-quickcheck)[arguments]: Add a phase that patches the Cabal file to allow newer versions of QuickCheck. (ghc-chell-quickcheck-bootstrap)[arguments]: Ditto.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c4eee42a6a..1294671e76 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7455,7 +7455,14 @@ testing strategies.")
("ghc-random" ,ghc-random)
("ghc-quickcheck" ,ghc-quickcheck)))
(arguments
- `(#:tests? #f))
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'update-constraints
+ (lambda _
+ (substitute* "chell-quickcheck.cabal"
+ (("QuickCheck >= 2\\.3 && < 2\\.11")
+ "QuickCheck >= 2.3 && < 2.12")))))))
(home-page "https://john-millikin.com/software/chell/")
(synopsis "QuickCheck support for the Chell testing library")
(description "More complex tests for @code{chell}.")
@@ -7475,6 +7482,14 @@ testing strategies.")
(base32
"1iicsys9igx7m7n4l2b8djardmjy2ah5ibzp7kzs758h460fq53a"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'update-constraints
+ (lambda _
+ (substitute* "chell-quickcheck.cabal"
+ (("QuickCheck >= 2\\.3 && < 2\\.11")
+ "QuickCheck >= 2.3 && < 2.12")))))))
(inputs
`(("ghc-chell" ,ghc-chell)
("ghc-chell-quickcheck-bootstrap" ,ghc-chell-quickcheck-bootstrap)