aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2024-12-14 12:32:15 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-14 12:32:15 +0100
commit4a314f880be5c71b59b6d72a9b238b938c348563 (patch)
tree7e924ca1c9ddb0e06e9b9318a585a16eee69de74 /gnu
parent942942ee75542e684baaccdd26372cfa6e2bc2a2 (diff)
downloadguix-4a314f880be5c71b59b6d72a9b238b938c348563.tar.gz
guix-4a314f880be5c71b59b6d72a9b238b938c348563.zip
gnu: podman-compose: Fix build.
* gnu/packages/containers.scm (podman-compose)[native-inputs]: Add python-setuptools, python-wheel. Change-Id: I1127e9630a5aea9a8fcf3244025d81c92df74670
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/containers.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 4e3bb7ab4f..0755ba23f3 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -56,6 +56,7 @@
#:use-module (gnu packages networking)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
#:use-module (gnu packages rust-apps)
#:use-module (gnu packages selinux)
@@ -593,7 +594,7 @@ To get @code{podman machine} working, install @code{qemu-minimal}, and
(arguments
(list
#:test-flags #~(list "pytests")))
- (native-inputs (list python-pytest python-parameterized))
+ (native-inputs (list python-pytest python-parameterized python-setuptools python-wheel))
(propagated-inputs (list python-dotenv python-pyyaml))
(home-page "https://github.com/containers/podman-compose")
(synopsis "Script to run docker-compose.yml using podman")