aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-08-25 11:06:06 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-08-28 10:25:50 +0200
commit48d90820e4f621b6c9cecd9365cb8f90f5fdcf5e (patch)
treea82ce2c873b8d98fd4f84c95afd6f559c9de7800 /gnu
parentcf941786eea468e28977437b881d84c2c2a66e66 (diff)
downloadguix-48d90820e4f621b6c9cecd9365cb8f90f5fdcf5e.tar.gz
guix-48d90820e4f621b6c9cecd9365cb8f90f5fdcf5e.zip
gnu: Add r-oompadata.
* gnu/packages/cran.scm (r-oompadata): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6c67f50fa4..ee45640f3d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2314,6 +2314,29 @@ higher.")
@url{https://www.oenb.at/en/Statistics/User-Defined-Tables/webservice.html}.")
(license license:gpl2+)))
+(define-public r-oompadata
+ (package
+ (name "r-oompadata")
+ (version "3.1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "oompaData" version))
+ (sha256
+ (base32
+ "0gdp7bghgpz3q0h06w8r926x7wkpcvkpyf0v5qfi1qixbpvk5fdf"))))
+ (properties `((upstream-name . "oompaData")))
+ (build-system r-build-system)
+ (home-page "http://oompa.r-forge.r-project.org/")
+ (synopsis "Data to illustrate OOMPA algorithms")
+ (description
+ "OOMPA offers R packages for gene expression and proteomics analysis.
+OOMPA uses S4 classes to construct object-oriented tools with a consistent
+user interface. All higher level analysis tools in OOMPA are compatible with
+the eSet classes defined in BioConductor. The lower level processing tools
+offer an alternative to parts of BioConductor, but can also be used to enhance
+existing BioConductor packages.")
+ (license license:asl2.0)))
+
(define-public r-orgmassspecr
(package
(name "r-orgmassspecr")