aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2024-11-06 08:40:39 +0800
committerHilton Chain <hako@ultrarare.space>2024-12-08 15:28:42 +0800
commit479deffa02a2dfdf93722f1044f67fddde92b004 (patch)
tree7bd461a524c169ce92edf6fb830edb2ee426132d /gnu
parent4b9a950a209eb36cce1a74ec709810b2a9937485 (diff)
downloadguix-479deffa02a2dfdf93722f1044f67fddde92b004.tar.gz
guix-479deffa02a2dfdf93722f1044f67fddde92b004.zip
gnu: Add hyprcursor.
* gnu/packages/wm.scm (hyprcursor): New variable. Change-Id: I3e753cbaf75244adca65f0478cabd10c89af4286
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xdisorg.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index a75e9cd6ba..033b86231e 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -115,6 +115,7 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gawk)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gl)
#:use-module (gnu packages gl)
@@ -3638,6 +3639,29 @@ and execute @file{.desktop} files of the Application type.")
This package is the fork of hsetroot by Hyriand.")
(license license:gpl2+)))
+(define-public hyprcursor
+ (package
+ (name "hyprcursor")
+ (version "0.1.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hyprwm/hyprcursor")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rdn03ln7pqcwp8h4nmi7nc489q8y25dd3v4paq8ykvwzhvs3a1n"))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #f)) ;TODO: No themes currently packaged.
+ (native-inputs (list gcc-13 pkg-config))
+ (inputs (list cairo hyprlang (librsvg-for-system) libzip tomlplusplus))
+ (home-page "https://standards.hyprland.org/hyprcursor/")
+ (synopsis "Cursor theme format")
+ (description
+ "This package provides Hyprland cursor format, library and utilities.")
+ (license license:bsd-3)))
+
(define-public jumpapp
(package
(name "jumpapp")