aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:23:52 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:09 +0200
commit463710da2352c6225ca834e98ddd878e2e945066 (patch)
tree9ee1a36c8cac6f7f5a58f73535fbe69ac6437818 /gnu
parentdcff8457b1244610ef7773cdf8672d41cf2d73ce (diff)
downloadguix-463710da2352c6225ca834e98ddd878e2e945066.tar.gz
guix-463710da2352c6225ca834e98ddd878e2e945066.zip
gnu: Add texlive-barracuda.
* gnu/packages/tex.scm (texlive-barracuda): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b44bcc91f6..039834d31f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14890,6 +14890,27 @@ Niepraschk. The package allows the use of LuaLaTeX together with PostScript
related code, e.g., PSTricks.")
(license license:lppl1.3c)))
+(define-public texlive-barracuda
+ (package
+ (name "texlive-barracuda")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/luatex/barracuda/" "scripts/barracuda/"
+ "tex/luatex/barracuda/")
+ (base32
+ "1v318nbbbp2klp0rykzb3skqqw4hhj1hbliigmp3qh34iiq3wqh0")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/barracuda")
+ (synopsis "Draw barcodes with Lua")
+ (description
+ "The Barracuda library is a modular Lua package for drawing barcode
+symbols. It provides modules for writing barcodes from a LuaTeX document. It
+is also possible to use Barracuda with a standalone Lua interpreter to draw
+barcodes in different graphic formats like SVG.")
+ (license license:gpl2)))
+
(define-public texlive-qrcode
(package
(name "texlive-qrcode")