aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-25 20:23:13 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:32 +0000
commit46038c4f44b1a9b34d83e4bc18ecb6c25e91bd5d (patch)
tree72126caf984b701c456d9e5efaf19609fa446ee1 /gnu
parente6896b25fcc1317a4c694b1eaf679e5cad15f474 (diff)
downloadguix-46038c4f44b1a9b34d83e4bc18ecb6c25e91bd5d.tar.gz
guix-46038c4f44b1a9b34d83e4bc18ecb6c25e91bd5d.zip
gnu: python-pytest-relaxed: Update to 2.0.2.
* gnu/packages/check.scm (python-pytest-relaxed): Update to 2.0.2. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I8c94f48bc7ad97421ba4043334d3d2315f5ec391
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 8f7cc94b1f..6e4fc694e0 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1677,7 +1677,7 @@ supports coverage of subprocesses.")
(define-public python-pytest-relaxed
(package
(name "python-pytest-relaxed")
- (version "2.0.1")
+ (version "2.0.2")
(source
(origin
(method git-fetch)
@@ -1686,10 +1686,14 @@ supports coverage of subprocesses.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1lnnkadfr390i30209gpl80nymc20pmamvxjhd11gvf4d6f54n7x"))))
+ (base32 "0j37gkgcag4rpv9g5q2n80425cs1alwx8fwncx3mv7sdgqgdgqnz"))))
(build-system pyproject-build-system)
- (propagated-inputs (list python-decorator))
- (native-inputs (list python-pytest))
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-decorator))
(home-page "https://github.com/bitprophet/pytest-relaxed")
(synopsis "Relaxed test discovery for pytest")
(description "This package provides relaxed test discovery for pytest.")