aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-10 14:40:29 +0200
committerMarius Bakke <marius@gnu.org>2022-09-10 14:40:29 +0200
commit45c2da38758f1cb75b2044440c78202ed26b881c (patch)
treee4b2468e9bf80ec3eef077b65d5b0654b65f110d /gnu
parent966649a74c120cabda4abc31b597ddd202ea71ca (diff)
downloadguix-45c2da38758f1cb75b2044440c78202ed26b881c.tar.gz
guix-45c2da38758f1cb75b2044440c78202ed26b881c.zip
gnu: gnome-shell: Remove obsolete input.
* gnu/packages/gnome.scm (gnome-shell)[arguments]: Don't remove intltool from XDG_DATA_DIRS. [native-inputs]: Remove INTLTOOL. Add GETTEXT-MINIMAL and PERL.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3873f783f7..f1ec619ef8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8815,19 +8815,20 @@ printf '~a is deprecated. Use the \"gnome-extensions\" CLI or \
(replace 'glib-or-gtk-wrap
(let ((wrap (assoc-ref %standard-phases 'glib-or-gtk-wrap)))
(lambda* (#:key inputs outputs #:allow-other-keys #:rest rest)
- ;; By default intltool et al. would end up in the XDG_DATA_DIRS
+ ;; By default glib:bin et al. would end up in the XDG_DATA_DIRS
;; settings of the wrappers created by the 'glib-or-gtk-wrap'
;; phase. Fix that since we don't need these.
(wrap #:inputs (fold alist-delete inputs
- '("intltool" "glib:bin"))
+ '("glib:bin"))
#:outputs outputs)))))))
(native-inputs
`(("asciidoc" ,asciidoc)
+ ("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
("gobject-introspection" ,gobject-introspection)
("hicolor-icon-theme" ,hicolor-icon-theme)
- ("intltool" ,intltool)
+ ("perl" ,perl)
("pkg-config" ,pkg-config)
("python" ,python)
("ruby-sass" ,ruby-sass)