aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-11-03 16:39:20 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-03 08:33:12 +0100
commit43ba6d2a0d9f8a697c6d70c6ab7ae3ee18a31552 (patch)
tree867e2b7bc9ceffd5aec436213a7aebac9902025c /gnu
parent59289e1cdd788725e5471a6a7367bcb7d6e09bf3 (diff)
downloadguix-43ba6d2a0d9f8a697c6d70c6ab7ae3ee18a31552.tar.gz
guix-43ba6d2a0d9f8a697c6d70c6ab7ae3ee18a31552.zip
gnu: elfutils: Fix build for 64bit Hurd.
* gnu/packages/elf.scm (elfutils)[arguments]: When building for a 64bit Hurd, set #:make-flags. Change-Id: I00abf360a7de5b1f78c1e912f0dcf27c62c1af68
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/elf.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 119f8d13dd..81a753a483 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
-;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2023, 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -86,6 +86,10 @@
"--disable-libdebuginfod"
"--disable-debuginfod")
+ ,@(if (target-hurd64?)
+ '(#:make-flags '("core-file_no_Werror=yes"))
+ '())
+
;; Disable tests on MIPS and PowerPC (without changing
;; the arguments list on other systems).
,@(if (any (cute string-prefix? <> (or (%current-target-system)