aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-02 21:03:21 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:42 +0000
commit4349a55ef7c193bea5fae79a12fe68920f32ce4b (patch)
tree210a93e2a6e79ee845456a1ca12e768521fe96af /gnu
parent9e00e66b86e7d078a6bf33d7d0bb2c442d875b3b (diff)
downloadguix-4349a55ef7c193bea5fae79a12fe68920f32ce4b.tar.gz
guix-4349a55ef7c193bea5fae79a12fe68920f32ce4b.zip
gnu: python-base58: Adjust inputs.
* gnu/packages/python-crypto.scm (python-base58) [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Ie9d7e2f043bdbbba711223cae99c8bd5d5e0e2c9
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-crypto.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 5db0b320f6..bf2a532cf4 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -89,22 +89,19 @@
(method url-fetch)
(uri (pypi-uri "base58" version))
(sha256
- (base32
- "1317ly0db7nnjg5k58f6nqa0svfcvn446xd5bpiyi0bfbczwpl65"))))
+ (base32 "1317ly0db7nnjg5k58f6nqa0svfcvn446xd5bpiyi0bfbczwpl65"))))
(build-system pyproject-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests? (invoke "pytest" "-vv")))))))
(native-inputs
- (list python-pyhamcrest python-pytest python-pytest-benchmark))
+ (list python-pyhamcrest
+ python-pytest
+ python-pytest-benchmark
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/keis/base58")
(synopsis "Base58 and Base58Check implementation")
- (description "Base58 and Base58Check implementation compatible
-with what is used by the Bitcoin network.")
+ (description
+ "Base58 and Base58Check implementation compatible with what is used by
+the Bitcoin network.")
(license license:expat)))
(define-public python-bcrypt